HDU 1029

Ignatius and the Princess IV

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32767 K (Java/Others)
Total Submission(s): 14591    Accepted Submission(s): 5934


Problem Description
"OK, you are not too bad, em... But you can never pass the next test." feng5166 says.

"I will tell you an odd number N, and then N integers. There will be a special integer among them, you have to tell me which integer is the special one after I tell you all the integers." feng5166 says.

"But what is the characteristic of the special integer?" Ignatius asks.

"The integer will appear at least (N+1)/2 times. If you can't find the right integer, I will kill the Princess, and you will be my dinner, too. Hahahaha....." feng5166 says.

Can you find the special integer for Ignatius?
 

Input
The input contains several test cases. Each test case contains two lines. The first line consists of an odd integer N(1<=N<=999999) which indicate the number of the integers feng5166 will tell our hero. The second line contains the N integers. The input is terminated by the end of file.
 

Output
For each test case, you have to output only one line which contains the special number you have found.
 

Sample Input
  
  
5 1 3 2 3 3 11 1 1 1 1 1 5 5 5 5 5 5 7 1 1 1 1 1 1 1
 

Sample Output
  
  
3 5 1
 

题目大意: 计算出数组中个数大于 N+1 / 2 的数 
解题方法一 : 可以认为是种位数, 因此只要将其进行排序就可以了;
#include<iostream>
#include<algorithm>

using namespace std;

int a[1000000];

int cmp(const void *a, const  void *b)
{
    return *(int*)a - *(int*)b;
}
int main()
{
    int i, n;
    while(cin>>n)
    {
        for(i = 0 ; i < n; i++)
        {
            cin>>a[i];
        }
        qsort(a, n, sizeof(int),cmp);
        cout<<a[(n-1)/2]<<endl;
    }
}


编程之美中给来另外一种高效率的解法 :   
编程之美  寻找发帖水王 
                即找到 ID大于一半的人
#include<iostream>
using namespace  std;

int a[1000000];
int main ()
{
    int n , i;
    while(cin>>n)
    {


    for(i = 0 ; i < n; i++)
    {
        cin>>a[i];
    }
    int candate ;
    int iTimes = 0;
    for(i = 0; i < n; i++)
    {//最后输出的candate 就会是结果
        if(iTimes == 0)
        {//从句收开始进行遍历
            candate = a[i] ;
            iTimes = 1;
        }

            else if(candate == a[i])
            {//找到了一个相同的数字
                iTimes++;

            }
            else
            {//两个数字不相同
                iTimes-- ;
            }
    }
    cout<<candate<<endl;
    }
    return 0 ;
}





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

wangxiaoming

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值