营救天使(bfs)

营救天使 分享至QQ空间 去爱问答提问或回答

Time Limit(Common/Java):1000MS/10000MS     Memory Limit:65536KByte
Total Submit: 46            Accepted: 17

Description

Angel was caught by the MOLIGPY! He was put in prison by Moligpy. The prison is described as a N * M (N, M <= 200) matrix. There are WALLs, ROADs, and GUARDs in the prison.

Angel's friends want to save Angel. Their task is: approach Angel. We assume that "approach Angel" is to get to the position where Angel stays. When there's a guard in the grid, we must kill him (or her?) to move into the grid. We assume that we moving up, down, right, left takes us 1 unit time, and killing a guard takes 1 unit time, too. And we are strong enough to kill all the guards.

You have to calculate the minimal time to approach Angel. (We can move only UP, DOWN, LEFT and RIGHT, to the neighbor grid within bound, of course.)

Input

First line contains two integers stand for N and M.

Then N lines follows, every line has M characters. "." stands for road, "a" stands for Angel, "x" stands for a guard, and "r" stands for each of Angel's friend. 

Process to the end of the file.

Output

For each test case, your program should output a single integer, standing for the minimal time needed. If such a number does no exist, you should output a line containing "Poor ANGEL has to stay in the prison all his life."

Sample Input


7 8
#.#####.
#.a#..r.
#..#x...
..#..#.#
#...##..
.#......
........

Sample Output

13
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <queue>
#include <cmath>
const int INF = 0x7fffffff;
using namespace std;
const int maxn = 210;

char g[maxn][maxn];
int n, m, res;
int used[maxn][maxn];
struct info {
    int x;
    int y;
    int time;
};
//从天使所在的地方开始搜索,逆向思维.
info start, endx;
queue<info> Q;

void init() {
    res = 0;
    while(!Q.empty()) Q.pop();
    memset(g, '\0', sizeof(g));
    for(int i = 0; i < maxn; i++)  {
        for(int j = 0; j < maxn; j++) {
            used[i][j] = INF;
        }
    }
}

void bfs() {
   Q.push(start);
   info tmp, in;
   while(!Q.empty()) {
        tmp = Q.front();
        Q.pop();
        if(g[tmp.x][tmp.y] == 'r') continue;
        if(tmp.x + 1 <= n && g[tmp.x+1][tmp.y] != '#') {// down
            in.x = tmp.x + 1;
            in.y = tmp.y;
            in.time = tmp.time + 1;
            if(g[in.x][in.y] == 'x') {
                in.time ++;
            }
            if(used[in.x][in.y] > in.time) {
                used[in.x][in.y] = in.time;
                Q.push(in);
            }
        }
        if(tmp.x-1 >= 1  && g[tmp.x-1][tmp.y] != '#') {// up
            in.x = tmp.x - 1;
            in.y = tmp.y;
            in.time = tmp.time + 1;
            if(g[in.x][in.y] == 'x') {
                in.time ++;
            }
            if(used[in.x][in.y] > in.time) {
                used[in.x][in.y] = in.time;
                Q.push(in);
            }
        }
        if(tmp.y-1>=1 && g[tmp.x][tmp.y-1] != '#') {// left
            in.x = tmp.x;
            in.y = tmp.y - 1;
            in.time = tmp.time + 1;
            if(g[in.x][in.y] == 'x') {
                in.time ++;
            }
            if(used[in.x][in.y] > in.time) {
                used[in.x][in.y] = in.time;
                Q.push(in);
            }
        }
        if(tmp.y+1 <= m && g[tmp.x][tmp.y+1] != '#') {//right
            in.x = tmp.x;
            in.y = tmp.y + 1;
            in.time = tmp.time + 1;
            if(g[in.x][in.y] == 'x') {
                in.time ++;
            }
            if(used[in.x][in.y] > in.time) {
                used[in.x][in.y] = in.time;
                Q.push(in);
            }
        }
   }
}

int main()
{
    int i, j;
    while(scanf("%d%d", &n, &m) != EOF) {
        init();
        for(i = 1; i <= n; i++) {
            scanf("%s", g[i] + 1);
        }
        for(i = 1; i <= n; i++) {
            for(j = 1; j <= m; j++) {
                if(g[i][j]=='a') {
                    start.x = i;
                    start.y = j;
                    start.time = 0;
                    used[i][j] = 0;
                }
            }
        }
        bfs();
        int minv = INF;
        for(i = 1; i <= n; i++) {
            for(j = 1; j <= m; j++) {
                if(g[i][j]=='r') {
                    minv = min(minv, used[i][j]);
                }
            }
        }
        if(minv != INF) {
            printf("%d\n", minv);
        }else {
            printf("Poor ANGEL has to stay in the prison all his life.\n");
        }
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值