Suppose that all the keys in a binary tree are distinct positive integers. Given the postorder and inorder traversal sequences, you are supposed to output the level order traversal sequence of the corresponding binary tree.
Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N (<=30), the total number of nodes in the binary tree. The second line gives the postorder sequence and the third line gives the inorder sequence. All the numbers in a line are separated by a space.
Output Specification:
For each test case, print in one line the level order traversal sequence of the corresponding binary tree. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.
Sample Input:
7
2 3 1 5 7 6 4
1 2 3 4 5 6 7
Sample Output:
4 1 6 3 5 7 2
思考:经典的数据结构基础。
#include <iostream>
#include <cstdio>
#include <queue>
using namespace std;
const int maxn = 50;
struct node {
int value;
node *leftChild;
node *rightChild;
};
node* buildTree(int postL, int postR, int inL, int inR, int post[], int in[]) {
if(postL > postR) return NULL;
node *root = new node();
root->value = post[postR];
int k;
for(k = inL; k <= inR; k++) {
if(in[k] == post[postR]) {
break;
}
}
int numLeft = k - inL;
root->leftChild = buildTree(postL, postL+numLeft-1, inL, k-1, post, in);
root->rightChild = buildTree(postL+numLeft, postR-1, k+1, inR, post, in);
return root;
}
void travel(node *root, const int n) {
queue<node*> Q;
if(root) {
Q.push(root);
}
int num = 1;
while(!Q.empty()) {
node* u = Q.front();
Q.pop();
if(num < n) {
printf("%d ", u->value);
num++;
}
else {
printf("%d\n", u->value);
return;
}
if(u->leftChild) Q.push(u->leftChild);
if(u->rightChild) Q.push(u->rightChild);
}
}
int main()
{
int n;
int post[maxn];
int in[maxn];
scanf("%d", &n);
for(int i = 0; i < n; i++) {
scanf("%d", &post[i]);
}
for(int i = 0; i < n; i++) {
scanf("%d", &in[i]);
}
node *root = buildTree(0, n-1, 0, n-1, post, in);
travel(root, n);
return 0;
}