POJ1269 Intersecting Lines

Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 8206 Accepted: 3736

Description

We all know that a pair of distinct points on a plane defines a line and that a pair of lines on a plane will intersect in one of three ways: 1) no intersection because they are parallel, 2) intersect in a line because they are on top of one another (i.e. they are the same line), 3) intersect in a point. In this problem you will use your algebraic knowledge to create a program that determines how and where two lines intersect.
Your program will repeatedly read in four points that define two lines in the x-y plane and determine how and where the lines intersect. All numbers required by this problem will be reasonable, say between -1000 and 1000.

Input

The first line contains an integer N between 1 and 10 describing how many pairs of lines are represented. The next N lines will each contain eight integers. These integers represent the coordinates of four points on the plane in the order x1y1x2y2x3y3x4y4. Thus each of these input lines represents two lines on the plane: the line through (x1,y1) and (x2,y2) and the line through (x3,y3) and (x4,y4). The point (x1,y1) is always distinct from (x2,y2). Likewise with (x3,y3) and (x4,y4).

Output

There should be N+2 lines of output. The first line of output should read INTERSECTING LINES OUTPUT. There will then be one line of output for each pair of planar lines represented by a line of input, describing how the lines intersect: none, line, or point. If the intersection is a point then your program should output the x and y coordinates of the point, correct to two decimal places. The final line of output should read "END OF OUTPUT".

Sample Input

5
0 0 4 4 0 4 4 0
5 0 7 6 1 0 2 3
5 0 7 6 3 -6 4 -3
2 0 2 27 1 5 18 5
0 3 4 0 1 2 2 5

Sample Output

INTERSECTING LINES OUTPUT
POINT 2.00 2.00
NONE
LINE
POINT 2.00 5.00
POINT 1.07 2.20
END OF OUTPUT
思路:判断直线间的关系,注意在区分平行不相交和平行相交的情况,我用的直线的一般式,深刻体会到C++在实现算法方面的简洁方便!
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <vector>
//1269	Accepted	172K	0MS	C++	2353B	2013-06-04 21:21:17
using namespace std;
const double eps = 1e-8;
int dcmp(double x) {
    if(fabs(x)<eps) return 0;
    if(x>0) return 1;
    return -1;
}

struct point {
    double x;
    double y;
    point() {}
    point(double a, double b) : x(a), y(b){}
};

point operator - (const point &a, const point &b) {
    return point(a.x-b.x, a.y-b.y);
}
point operator +(const point &a, const point &b) {
    return point(a.x+b.x, a.y+b.y);
}

double det(const point a, const point b) {
    return a.x*b.y - a.y*b.x;
}
double dot(const point a, const point b) {
    return a.x*b.x + a.y*b.y;
}

point operator * (const double p, const point &a) {
    return point(a.x*p, a.y*p);
}

point operator / (const point a, const double p) {
    return point(a.x/p, a.y/p);
}

struct line {
    point a, b;
    line() {}
    line(point x, point y):a(x), b(y) {}
};

bool parallel(line a, line b) {
    return !dcmp(det(a.a-a.b, b.a-b.b));
}

bool line_make_point(line a, line b, point &res) {
    if(parallel(a, b)) return false;
    double s1 = det(a.a-b.a, b.b-b.a);
    double s2 = det(a.b-b.a, b.b-b.a);
    res = (s1*a.b - s2*a.a)/(s1-s2);
    return true;
}

bool is_point_online(line v, point b) {
    double A, B, C;
    A = v.b.y - v.a.y;
    B = v.a.x - v.b.x;
    C = det(v.b, v.a);
    if(dcmp(A*b.x+B*b.y+C)==0) {
        return true;
    }
    return false;
}

int main()
{
    int T;
    scanf("%d", &T);
    double x1, y1, x2, y2, x3, y3, x4, y4;
    printf("INTERSECTING LINES OUTPUT\n");
    while(T--) {
        scanf("%lf%lf%lf%lf", &x1, &y1, &x2, &y2);
        scanf("%lf%lf%lf%lf", &x3, &y3, &x4, &y4);
        line a(point(x1, y1), point(x2, y2));
        line b(point(x3, y3), point(x4, y4));
        bool ans = parallel(a, b);
        if(ans&&is_point_online(a, b.a)) {
            printf("LINE\n");
            continue;
        }
        if(ans) {
            printf("NONE\n");
            continue;
        }
        bool flag = false;
        point res;
        flag = line_make_point(a, b, res);
        if(flag) {
            printf("POINT %.2lf %.2lf\n", res.x, res.y);
        }
    }
    printf("END OF OUTPUT\n");
    return 0;
}


 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值