Floyd Warshall---Frogger

Floyd Warshall—Frogger

题目:

Freddy Frog is sitting on a stone in the middle of a lake. Suddenly he notices Fiona Frog who is sitting on another stone. He plans to visit her, but since the water is dirty and full of tourists’ sunscreen, he wants to avoid swimming and instead reach her by jumping.
Unfortunately Fiona’s stone is out of his jump range. Therefore Freddy considers to use other stones as intermediate stops and reach her by a sequence of several small jumps.
To execute a given sequence of jumps, a frog’s jump range obviously must be at least as long as the longest jump occuring in the sequence.
The frog distance (humans also call it minimax distance) between two stones therefore is defined as the minimum necessary jump range over all possible paths between the two stones.

You are given the coordinates of Freddy’s stone, Fiona’s stone and all other stones in the lake. Your job is to compute the frog distance between Freddy’s and Fiona’s stone.
Input
The input will contain one or more test cases. The first line of each test case will contain the number of stones n (2<=n<=200). The next n lines each contain two integers xi,yi (0 <= xi,yi <= 1000) representing the coordinates of stone #i. Stone #1 is Freddy’s stone, stone #2 is Fiona’s stone, the other n-2 stones are unoccupied. There’s a blank line following each test case. Input is terminated by a value of zero (0) for n.
Output
For each test case, print a line saying “Scenario #x” and a line saying “Frog Distance = y” where x is replaced by the test case number (they are numbered from 1) and y is replaced by the appropriate real number, printed to three decimals. Put a blank line after each test case, even after the last one.

Sample Input

2
0 0
3 4
	
3
17 4
19 4
18 5

0

Sample Output

Scenario #1
Frog Distance = 5.000
	
Scenario #2
Frog Distance = 1.414

题意:

给出n块石头的坐标,先算出任意两块石头间的距离,然后有两只青蛙,Freddy青蛙(从1号石头)想去找Fiona(到2号石头)叙旧,无奈腿短,一步可能跳不到,请你帮他一把(求他所走的最短路上的最大跳跃距离是多少),让他如愿以偿。

思路:

首先,要借助第三块石头求出1–>3和3–>2的距离的最大值,拿最大值再与1–>2的距离相比较,取最小值(这就是青蛙一步之内能跳的极限距离),但极限距离不是固定的,要把剩下n-2个石头全部遍历一遍才能找到这个极限距离,也是本题的答案。

举个“栗子”:

7
2
3
3
4
5
4
1
2
3
4
5

比如说,1-3之间的距离是2;3-4之间的距离是3;青蛙要想从1号石头跳到4号石头上,(前提是不能直接跳到4号石头上,否则直接就是1-4的距离了)那么它一步就必须是3,如果是2的话,那3号石头到4号石头就跳不过去了,然后与1-4的距离比较,选出最小值就是极限距离,剩下的石头求极限距离同上。
其次,要用到Floyd Warshall算法的变形:

for(k=1;k<=n;k++)
	for(i=1;i<=n;i++)
		for(j=1;j<=n;j++)
			d[i][j]=min(d[i][j],max(d[i][k],d[k][j]));	

好了,话不多说,代码安排上。

代码:

#include<stdio.h>
#include<math.h>
#include<algorithm>
using namespace std;
int a[1001],b[1001];
int inf=99999999;
double d[1001][1001];
int main()
{
	int n,i,j,k;
	int sum=0;
	while(~scanf("%d",&n)&&n)
	{
		sum++;       //记录测试样例的个数
		for(i=1;i<=n;i++)    //先把二维数组初始化
			for(j=1;j<=n;j++)
				if(i==j)
					d[i][j]=0; //起点和终点都是一个点,赋值为0
				else
					d[i][j]=inf; //否则全部为无穷大,若为无穷大表示两点间不通路
		for(i=1;i<=n;i++)
		scanf("%d%d",&a[i],&b[i]);
		for(i=1;i<=n;i++)
			for(j=1;j<=n;j++)
				d[i][j]=d[j][i]=sqrt(pow(a[i]-a[j],2.0)+pow(b[i]-b[j],2.0));//赋值,录入任意两点间的距离
		for(k=1;k<=n;k++)   //Floyd Warshall算法核心
			for(i=1;i<=n;i++)
				for(j=1;j<=n;j++)
					d[i][j]=min(d[i][j],max(d[i][k],d[k][j]));//最短路上的最大跳跃距离
	 printf("Scenario #%d\n",sum);
	 printf("Frog Distance = %.3lf\n\n",d[1][2]);//注意题目要求,每个测试样例结束要空开一行
	}
	return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值