Just a Hook(线段树+区间更新+区间求和)

Just a Hook

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 40016    Accepted Submission(s): 19366


Problem Description
In the game of DotA, Pudge’s meat hook is actually the most horrible thing for most of the heroes. The hook is made up of several consecutive metallic sticks which are of the same length.



Now Pudge wants to do some operations on the hook.

Let us number the consecutive metallic sticks of the hook from 1 to N. For each operation, Pudge can change the consecutive metallic sticks, numbered from X to Y, into cupreous sticks, silver sticks or golden sticks.
The total value of the hook is calculated as the sum of values of N metallic sticks. More precisely, the value for each kind of stick is calculated as follows:

For each cupreous stick, the value is 1.
For each silver stick, the value is 2.
For each golden stick, the value is 3.

Pudge wants to know the total value of the hook after performing the operations.
You may consider the original hook is made up of cupreous sticks.
 

Input
The input consists of several test cases. The first line of the input is the number of the cases. There are no more than 10 cases.
For each case, the first line contains an integer N, 1<=N<=100,000, which is the number of the sticks of Pudge’s meat hook and the second line contains an integer Q, 0<=Q<=100,000, which is the number of the operations.
Next Q lines, each line contains three integers X, Y, 1<=X<=Y<=N, Z, 1<=Z<=3, which defines an operation: change the sticks numbered from X to Y into the metal kind Z, where Z=1 represents the cupreous kind, Z=2 represents the silver kind and Z=3 represents the golden kind.
 

Output
For each case, print a number in a line representing the total value of the hook after the operations. Use the format in the example.
 

Sample Input
 
 
11021 5 25 9 3
 

Sample Output
 
 
Case 1: The total value of the hook is 24.

具体题解点这里

#include <iostream>
#include <string.h>
#define size 262144
using namespace std;
int A[size];  // 原始数据
int tree[size]; // 线段树
int lazy[size]; // 懒惰标记

// 更新节点值
void PushUp(int p) {
	tree[p] = tree[p * 2] + tree[p * 2 + 1];
}

// 下推标记
void PushDown(int p, int l_num, int r_num) { // p为当前树节点,l_num为左子树的区间长度, r_num为右子树的区间长度
	if (lazy[p] != 0) {
		lazy[p * 2] = lazy[p];
		lazy[p * 2 + 1] = lazy[p];
		tree[p * 2] = lazy[p] * l_num;
		tree[p * 2 + 1] = lazy[p * 2 + 1] * r_num;
		lazy[p] = 0;
	}
}

// 初始化线段树
void Build(int l, int r, int p) { // [l,r]为区间, p为树的节点
	if (l == r) { // 到达叶子节点
		tree[p] = A[l];
		return;
	}

	int m = (l + r) / 2;
	Build(l, m, p * 2);
	Build(m + 1, r, p * 2 + 1);
	PushUp(p);
}

// 区域操作
void Update(int L, int R, int C, int l, int r, int p) { // A[T] = C, [l,r]为区间, p为树的节点
														// 到达叶子节点,递归修改完成
	if (L <= l && r <= R) {
		tree[p] = (r - l + 1)*C;
		lazy[p] = C;
		return;
	}
	int m = (l + r) / 2;
	// 先下推
	PushDown(p, m - l + 1, r - m);
	// 二分范围递归
	if (L <= m)
		Update(L, R, C, l, m, p * 2);
	if (R >= m + 1)
		Update(L, R, C, m + 1, r, p * 2 + 1);
	// 最后更新当前节点值
	PushUp(p);
}

// 查询操作
int Query(int L, int R, int l, int r, int p) { // 查询区间[L,R], 当前区间[l,r], p为树的节点
	if (L <= l && r <= R) { // [l,r] <= [L,R] 说明当前查询的区间值为[L,R]区间值的一部分,返回
		return tree[p];
	}
	int m = (l + r) / 2;
	PushDown(p, m - l + 1, m - r);

	int ans = 0;
	// 这里判断左右子树跟[L,R]有无交集,有交集才递归 
	if (L <= m)
		ans += Query(L, R, l, m, p * 2);
	if (R >= m + 1)
		ans += Query(L, R, m + 1, r, p * 2 + 1);
	return ans;
}


int main() {
	//freopen("1.txt", "r", stdin);
	int t;
	int T, N, Q;
	scanf("%d", &T);
	t = T;
	while (T--) {
		printf("Case %d: ", t - T);
		scanf("%d", &N);
		for (int i = 1; i <= N; i++)
			A[i] = 1;
		memset(tree, 0, size);
		memset(lazy, 0, size);
		Build(1, N, 1);
		scanf("%d", &Q);
		while (Q--) {
			int num1, num2, C;
			scanf("%d %d %d", &num1, &num2, &C);
			Update(num1, num2, C, 1, N, 1);
		}
		printf("The total value of the hook is %d.\n", Query(1, N, 1, N, 1));
	}
	return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值