ZOJ 2110 Tempter of the Bone (DFS)

8 篇文章 0 订阅

Tempter of the Bone

Time Limit: 2 Seconds      Memory Limit: 65536 KB

The doggie found a bone in an ancient maze, which fascinated him a lot. However, when he picked it up, the maze began to shake, and the doggie could feel the ground sinking. He realized that the bone was a trap, and he tried desperately to get out of this maze.

The maze was a rectangle with sizes N by M. There was a door in the maze. At the beginning, the door was closed and it would open at the T-th second for a short period of time (less than 1 second). Therefore the doggie had to arrive at the door on exactly the T-th second. In every second, he could move one block to one of the upper, lower, left and right neighboring blocks. Once he entered a block, the ground of this block would start to sink and disappear in the next second. He could not stay at one block for more than one second, nor could he move into a visited block. Can the poor doggie survive? Please help him.


Input

The input consists of multiple test cases. The first line of each test case contains three integers N, M, and T (1 < N, M < 7; 0 < T < 50), which denote the sizes of the maze and the time at which the door will open, respectively. The next N lines give the maze layout, with each line containing M characters. A character is one of the following:

'X': a block of wall, which the doggie cannot enter;
'S': the start point of the doggie;
'D': the Door; or
'.': an empty block.

The input is terminated with three 0's. This test case is not to be processed.


Output

For each test case, print in one line "YES" if the doggie can survive, or "NO" otherwise.


Sample Input

4 4 5
S.X.
..X.
..XD
....
3 4 5
S.X.
..X.
...D
0 0 0


Sample Output


NO
YES


传送门:http://acm.zju.edu.cn/onlinejudge/showProblem.do?problemId=1110


题意:判断小狗要成功通过迷宫,小狗每次可以上下左右运动,但不能返回(走过的格子就不能再走了),如果能够在指定的时间到达出口则算成功,否则失败。


解题思路:dfs,尝试每一种可能的情况  可以适当剪枝


#include <iostream>
#include <cstdio>
#include <cmath>

using namespace std;
char map[9][9]; //储存迷宫
int n,m,t;//n->长 m->宽  t->time
int si,sj,di,dj,cnt;//si,sj->当前位置  di,dj->终点位置  cnt->recent time
bool escape;

int dir[4][2]={{0,-1},{0,1},{-1,0},{1,0} };

void dfs(int si,int sj,int cnt)
{
    if(si>m || sj>n || si<=0 ||sj<=0)     //遇到边界,结束
        return;
    if(si==di&&sj==dj&&cnt==t)
    {
        escape = true;
        return;
    }
    int temp,i;
    temp =t-(abs(di-si)+abs(dj-sj)+cnt);
    if(temp<0 || temp%2)   //剪枝
        return;
    for(i=0;i<4;i++)
    {
        if(map[si+dir[i][0]][sj+dir[i][1]]!='X')
        {
           map[si+dir[i][0]][sj+dir[i][1]]='X';
           dfs(si+dir[i][0],sj+dir[i][1],cnt+1);
           if(escape) return;
           map[si+dir[i][0]][sj+dir[i][1]]='.';
        }
    }
    return;
}


int main()
{
    //freopen("test.txt","r",stdin);
    int i,j,wall_num;
    while(cin>>m>>n>>t)
    {
        if(n==0 &&m==0 && t==0)
            break;
        wall_num = 0;
        for(i=1;i<=m;i++)
        {
            for(j=1;j<=n;j++)
            {
                cin>>map[i][j];
                if(map[i][j]=='X')
                    wall_num++;
                else if(map[i][j]=='S')
                {
                    si = i;sj = j;
                }
                else if(map[i][j]=='D')
                {
                    di=i;dj=j;
                }
            }
        }
        if(n*m-wall_num<=t)
        {
            cout<<"NO"<<endl;
            continue;
        }
        escape = false;
        map[si][sj]='X';
        dfs(si,sj,0);
        if(escape)
            cout<<"YES"<<endl;
        else
            cout<<"NO"<<endl;

    }
    return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值