hdoj1087 Super Jumping

hdoj1087 Super Jumping

时空限制    1000ms/64MB

【题目描述】

Nowadays, a kind of chess game called “Super Jumping! Jumping! Jumping!” is very popular in HDU. Maybe you are a good boy, and know little about this game, so I introduce it to you now.

The game can be played by two or more than two players. It consists of a chessboard(棋盘)and some chessmen(棋子), and all chessmen are marked by a positive integer or “start” or “end”. The player starts from start-point and must jumps into end-point finally. In the course of jumping, the player will visit the chessmen in the path, but everyone must jumps from one chessman to another absolutely bigger (you can assume start-point is a minimum and end-point is a maximum.). And all players cannot go backwards. One jumping can go from a chessman to next, also can go across many chessmen, and even you can straightly get to end-point from start-point. Of course you get zero point in this situation. A player is a winner if and only if he can get a bigger score according to his jumping solution. Note that your score comes from the sum of value on the chessmen in you jumping path.
Your task is to output the maximum value according to the given chessmen list.

如今,一种名为“超级跳跃!”的国际象棋游戏!跳!跳跃!“在HDU中很受欢迎。也许你是一个好孩子,对这个游戏知之甚少,所以我现在介绍给你。
游戏可以由两个或两个以上的玩家进行。它由棋盘和一些西洋棋棋子组成,所有西洋棋棋子都用正整数或“开始”或“结束”标记。玩家从起点开始,最后必须跳到终点。在跳跃过程中,玩家将访问路径中的西洋棋棋子,但是每个人都必须从一个棋子跳到另一个绝对更大的棋子(你可以假设起点是最小值,终点是最大值)。并且所有球员都不能倒退。一个跳跃可以从西洋棋棋子到下一个,也可以穿过许多西洋棋棋子,甚至你可以直接从起点到达终点。当然,在这种情况下,你得到零分。只有当他能够根据他的跳跃解决方案获得更高的分数时,玩家才是赢家。请注意,您的分数来自您跳跃路径中西洋棋棋子的价值总和。
您的任务是根据给定的西洋棋棋子列表输出最大值。

【输入】

Input contains multiple test cases. Each test case is described in a line as follow:
N value_1 value_2 …value_N
It is guarantied that N is not more than 1000 and all value_i are in the range of 32-int.
A test case starting with 0 terminates the input and this test case is not to be processed.

输入包含多个测试用例。 每个测试用例的描述如下:
N value_1 value_2 ... value_N
保证N不超过1000且所有value_i都在32-int范围内。
以0开头的测试用例终止输入,并且不处理该测试用例。

【输出】

For each case, print the maximum according to rules, and one line one case.

对于每种情况,根据规则打印最大值,并且一行打印一个。

【输入样例】

3 1 3 2
4 1 2 3 4
4 3 3 2 1
0

【输出样例】

4
10
3

 

代码

#include<iostream>
#include<algorithm>
using namespace std;
const int N = 1005;
int n,a[N],f[N];

int main(){
	while (cin>>n && n){
		for (int i=1; i<=n; i++){
			cin>>a[i];
			f[i] = a[i];
		}
		for (int i=2; i<=n; i++)
			for (int j=1; j<i; j++)
				if (a[j]<a[i]) f[i]=max(f[i],f[j]+a[i]);
		int ans=f[1];
		for (int i=2; i<=n; i++) ans=max(ans,f[i]);
		cout<<ans<<endl;
	}
	return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值