<?xml version="1.0" encoding="utf-8" ?><rss version="2.0"><channel><title><![CDATA[weiwu13的博客]]></title><description><![CDATA[]]></description><link>https://blog.csdn.net/weiwu13</link><language>zh-cn</language><generator>https://blog.csdn.net/</generator><copyright><![CDATA[Copyright &copy; weiwu13]]></copyright><item><title><![CDATA[当执行npm install puppeteer时报错“`PUPPETEER DOWNLOAD HOST is deprecated. Use PUPPETEER DOWNLOAD BASE URL]]></title><link>https://blog.csdn.net/weiwu13/article/details/140458672</link><guid>https://blog.csdn.net/weiwu13/article/details/140458672</guid><author>weiwu13</author><pubDate>Tue, 16 Jul 2024 10:18:03 +0800</pubDate><description><![CDATA[当执行npm install puppeteer时报错“解决办法就是执行一下这个语句：“]]></description><category></category></item><item><title><![CDATA[淘宝镜像到期如何切换新镜像]]></title><link>https://blog.csdn.net/weiwu13/article/details/140458511</link><guid>https://blog.csdn.net/weiwu13/article/details/140458511</guid><author>weiwu13</author><pubDate>Tue, 16 Jul 2024 10:13:42 +0800</pubDate><description><![CDATA[【代码】淘宝镜像到期如何切换新镜像。]]></description><category></category></item><item><title><![CDATA[启动rabbit MQ的服务的时候，提示“错误1067：进程意外停止。”的解决办法]]></title><link>https://blog.csdn.net/weiwu13/article/details/140319092</link><guid>https://blog.csdn.net/weiwu13/article/details/140319092</guid><author>weiwu13</author><pubDate>Wed, 10 Jul 2024 11:37:55 +0800</pubDate><description><![CDATA[启动rabbit MQ的服务的时候，提示“错误1067：进程意外停止。”]]></description><category></category></item><item><title><![CDATA[IDEA报错：与目标 VM 断开连接, 地址为: ‘‘127.0.0.1:57599‘，传输: ‘套接字‘‘的完美解决办法【仅个人】]]></title><link>https://blog.csdn.net/weiwu13/article/details/129583375</link><guid>https://blog.csdn.net/weiwu13/article/details/129583375</guid><author>weiwu13</author><pubDate>Thu, 16 Mar 2023 13:44:22 +0800</pubDate><description><![CDATA[３、最后将注册表信息中原来版本的JDK注册信息删掉【win+R，输入regedit，找到［HKEY_LOCAL_MACHINE]－[SOFTWARE]－[JavaSoft]文件夹，此文件夹是JDK的注册信息，将JavaSoft文件夹及其子文件夹都删除】而后与同事讨论，感觉是jdk版本太高的问题，声明这里用的是tomcat8.5.57，jdk用的是1.8.0_321，而后将这个版本的JDK删掉，然后安装了个1.8.0_131的版本，然后重新配置一下对应的环境变量及idea，重启就可正常启动系统了。]]></description><category></category></item><item><title><![CDATA[二维码生成器使用方法]]></title><link>https://blog.csdn.net/weiwu13/article/details/129261553</link><guid>https://blog.csdn.net/weiwu13/article/details/129261553</guid><author>weiwu13</author><pubDate>Tue, 28 Feb 2023 14:46:17 +0800</pubDate><description><![CDATA[可以直接在这个网址生成二维码，供测试使用。将上面这个输入进去，就可以生成一个二维码。]]></description><category></category></item><item><title><![CDATA[如何在Oracle中查看表是否被锁]]></title><link>https://blog.csdn.net/weiwu13/article/details/129260664</link><guid>https://blog.csdn.net/weiwu13/article/details/129260664</guid><author>weiwu13</author><pubDate>Tue, 28 Feb 2023 14:13:25 +0800</pubDate><description><![CDATA[如何在Oracle中查看表是否被锁]]></description><category></category></item><item><title><![CDATA[idea启动项目后出现 java: Compilation failed: internal java compiler error错误]]></title><link>https://blog.csdn.net/weiwu13/article/details/128216328</link><guid>https://blog.csdn.net/weiwu13/article/details/128216328</guid><author>weiwu13</author><pubDate>Wed, 07 Dec 2022 10:54:51 +0800</pubDate><description><![CDATA[idea启动项目后出现 java: Compilation failed: internal java compiler error错误
1、查看项目的jdk（Ctrl+Alt+shift+S）
File ->Project Structure->Project Settings ->Project

2、查看工程的jdk（Ctrl+Alt+shift+S）
File ——Project Structure——Project Settings —— Modules ）

3、File---->Setting]]></description><category></category></item><item><title><![CDATA[创建本地Oracle数据库或登录时遇到的问题汇总”TNS-03505““2、ORA-12505, TNS:listener does not currently know of SID given “]]></title><link>https://blog.csdn.net/weiwu13/article/details/128197663</link><guid>https://blog.csdn.net/weiwu13/article/details/128197663</guid><author>weiwu13</author><pubDate>Tue, 06 Dec 2022 10:52:03 +0800</pubDate><description><![CDATA[安装Oracle后，创建本地数据库的过程中遇到的一些问题汇总1、TNS-03505: 无法解析名称
解决办法：修改tnsnames.ora文件，将添加的orcl实例的数据写进去
解决后图片展示
2、ORA-12505, TNS:listener does not currently know of SID given in connect desc
给程序配置新数据库时，发生了该报错ORA-12505: TNS: 监听程序当前无法识别连接描述符中所给出的SID
说明给到的sid有误,很有可能就是服务名和si]]></description><category></category></item><item><title><![CDATA[达梦7数据库安装教程]]></title><link>https://blog.csdn.net/weiwu13/article/details/127537589</link><guid>https://blog.csdn.net/weiwu13/article/details/127537589</guid><author>weiwu13</author><pubDate>Thu, 27 Oct 2022 14:10:29 +0800</pubDate><description><![CDATA[达梦数据库安装教程]]></description><category></category></item><item><title><![CDATA[启动IDEA时，报错Caused by: java.lang.NoClassDefFoundError: javax/el/ELManager的解决办法]]></title><link>https://blog.csdn.net/weiwu13/article/details/127447295</link><guid>https://blog.csdn.net/weiwu13/article/details/127447295</guid><author>weiwu13</author><pubDate>Fri, 21 Oct 2022 15:33:03 +0800</pubDate><description><![CDATA[当重新安装IDEA，启动某个项目的时候，提示这个报错，本人表示一脸懵，没有遇见过这个问题，于是就开始了rebuild、maven之路，该试的都试过了，经过一天后，发现报错依旧是这个，无能为力了。最后寻求了帮助，发现犯了一个低级的错误。在这里，我的设置是Tomcat为8.5，结果在Tomcat Home那的是Tomcat7.0，重新设置后，就可以正常启动项目了。一般而言这里不会乱动，不知道为何会变成这样，可能是软件有它自己的想法？]]></description><category></category></item><item><title><![CDATA[当启动系统时，提示端口被占用的解决方法]]></title><link>https://blog.csdn.net/weiwu13/article/details/127257428</link><guid>https://blog.csdn.net/weiwu13/article/details/127257428</guid><author>weiwu13</author><pubDate>Tue, 11 Oct 2022 09:54:01 +0800</pubDate><description><![CDATA[有时候，我们在用IDEA去启动系统的时候，会提示XXXX端口被占用；因为往往会提示这个的时候，是因为我们在关闭IDEA的时候操作不恰当导致的。找到进程号后，我们接下来要操作的就是将这个进程干掉，输入“taskkill -pid 进程号 -f”，然后回车就可以了，该进程就会被干掉，接着启动IDEA运行系统就不会有问题了。首先WIN+R输入cmd进入命令窗口，然后在里面输入“netstat -ano | findstr 端口号”，得到下图，图中红色部分为进程号。]]></description><category></category></item><item><title><![CDATA[运行idea报错： Module was compiled with an incompatible version of Kotlin. The binary version of its meta]]></title><link>https://blog.csdn.net/weiwu13/article/details/127243367</link><guid>https://blog.csdn.net/weiwu13/article/details/127243367</guid><author>weiwu13</author><pubDate>Mon, 10 Oct 2022 14:02:50 +0800</pubDate><description><![CDATA[错误:Kotlin: Module was compiled with an incompatible version of Kotlin. The binary version of its metadata is 1.6.0, expected version is 1.1.16.不行的话，还可以尝试去settings的插件那，找到“Kotlin”插件，关闭再打开试试。这时候我们可以直接去rebuild project 一下，一般都是可以解决的。]]></description><category></category></item><item><title><![CDATA[登录Oracle时，报错：ORA-12638: 身份证明检索失败的解决方法]]></title><link>https://blog.csdn.net/weiwu13/article/details/127227028</link><guid>https://blog.csdn.net/weiwu13/article/details/127227028</guid><author>weiwu13</author><pubDate>Sun, 09 Oct 2022 15:11:06 +0800</pubDate><description><![CDATA[当登录PLSQL的时候，输入了账号密码之类的信息后登录提示了“ORA-12638: 身份证明检索失败”，对于这种情况的解决办法，可以通过修改“sqlnet.ora”文件的SQLNET.AUTHENTICATION_SERVICES = (NTS)中的“NTS”为“NONE”即可。修改后，重新登录即可成功登录；如果依旧提示该报错的话，可以重启下服务或者软件，再重新登录。ORA-12638: 身份证明检索失败。]]></description><category></category></item><item><title><![CDATA[命令行用impdp导入oracle时，报错ORA-02374: conversion error loading table “XXXX“.“XXXX“ ORA-12899: value……]]></title><link>https://blog.csdn.net/weiwu13/article/details/127111544</link><guid>https://blog.csdn.net/weiwu13/article/details/127111544</guid><author>weiwu13</author><pubDate>Thu, 29 Sep 2022 18:02:11 +0800</pubDate><description><![CDATA[ORA-12899: value too large for column 表名(actual: 66, maximum: 50)原因：源库是16GDK字符集   目标库是UTF-8字符集    两库字符集不相符。这都源于在新增数据库的时候，字符集那修改了不使用默认值，而是UTF-8导致。]]></description><category></category></item><item><title><![CDATA[在SVN安装目录的bin文件夹下没有找到svn.exe]]></title><link>https://blog.csdn.net/weiwu13/article/details/125767638</link><guid>https://blog.csdn.net/weiwu13/article/details/125767638</guid><author>weiwu13</author><pubDate>Wed, 13 Jul 2022 17:35:01 +0800</pubDate><description><![CDATA[SVN安装目录bin文件夹下没有svn.exe]]></description><category></category></item><item><title><![CDATA[当启动IDEA后报错：Cannot open URL. Please check this URL is correct:]]></title><link>https://blog.csdn.net/weiwu13/article/details/123702306</link><guid>https://blog.csdn.net/weiwu13/article/details/123702306</guid><author>weiwu13</author><pubDate>Thu, 24 Mar 2022 09:20:52 +0800</pubDate><description><![CDATA[最近新遇见的一个不算坑的坑
电脑没有设置固定的IP地址，导致重启电脑后都帮我重置IP地址，而本人没得注意，于是在启动idea后，提示地址错误，就去找原因

找了N久后都没发现问题出在哪里，试过的方法有：重新maven、重构建项目、清理项目……
最后突发奇想的，想看下自己的IP地址，于是一顿操作后，果然是……
下次出现该问题一定要记住先查看IP

...]]></description><category></category></item><item><title><![CDATA[如何用命令行启动Redis]]></title><link>https://blog.csdn.net/weiwu13/article/details/122976938</link><guid>https://blog.csdn.net/weiwu13/article/details/122976938</guid><author>weiwu13</author><pubDate>Thu, 17 Feb 2022 09:54:53 +0800</pubDate><description><![CDATA[1、命令行启动Redis
打开Redis安装目录，输入
redis-server.exe redis.windows.conf
2、给Redis设置密码
config set requirepass 123456
【此处的123456为密码】

]]></description><category></category></item><item><title><![CDATA[mysql1062错误： Duplicate entry ‘...‘ for key ‘PRIMARY]]></title><link>https://blog.csdn.net/weiwu13/article/details/122687915</link><guid>https://blog.csdn.net/weiwu13/article/details/122687915</guid><author>weiwu13</author><pubDate>Tue, 25 Jan 2022 16:35:01 +0800</pubDate><description><![CDATA[问题解释：
Duplicate entry ‘…’ for key ‘PRIMARY，即插入数据时，要插入数据的主键数据(…)已经存在，不能再重复添加了。例：Duplicate entry ‘0’ for key ‘PRIMARY是指主键为0的数据已经存在，不能再插入主键值为0的数据了。
问题解决：
在执行插入操作insert前，可以先执行一遍该主键值的查找操作select
【简单的来说，就是这个语句已经执行过了，无需重复执行】
1062、1060报错都是一样的



...]]></description><category></category></item><item><title><![CDATA[下载并安装node.js]]></title><link>https://blog.csdn.net/weiwu13/article/details/121768984</link><guid>https://blog.csdn.net/weiwu13/article/details/121768984</guid><author>weiwu13</author><pubDate>Tue, 07 Dec 2021 16:13:09 +0800</pubDate><description><![CDATA[下载并安装node.js
简介：http://nodejs.cn/learn
官网下载地址：http://nodejs.cn/download/










安装完成，会弹出这个页面


等待加载中期间要是弹出防火墙提示，请选择允许本次操作

直到这个界面出来了，就算是可以了

...]]></description><category></category></item><item><title><![CDATA[PL/SQL Developer登录时报错：“ORA-12638: 身份证明检索失败”]]></title><link>https://blog.csdn.net/weiwu13/article/details/121763803</link><guid>https://blog.csdn.net/weiwu13/article/details/121763803</guid><author>weiwu13</author><pubDate>Tue, 07 Dec 2021 11:13:03 +0800</pubDate><description><![CDATA[PL/SQL Developer登录时报错：“ORA-12638: 身份证明检索失败”

由于刚换了个新主机，发现登录某个服务器上的数据库都无法登录，都会提示“ORA-12638: 身份证明检索失败”，一开始以为是服务器那边屏蔽了该电脑的ip；但发现可以通过idea发布系统连接到服务器上的数据库，那么应该就是数据库软件的问题了，经过百度后发现需要更改个文件，重启软件即可登录成功。
首先在oracle的安装目录下找到这个文件“sqlnet.ora”，好像每个人的都有点不大一致的位置，建议搜索，我的目录是“\a]]></description><category></category></item></channel></rss>