java如何判断密码对错,1067. 试密码(20) (Java代码 19/20一个测试点报错,请有大佬发现哪儿错了一定指出,谢谢)...

当你试图登录某个系统却忘了密码时,系统一般只会允许你尝试有限多次,当超出允许次数时,账号就会被锁死。本题就请你实现这个小功能。

输入格式:

输入在第一行给出一个密码(长度不超过20的、不包含空格、Tab、回车的非空字符串)和一个正整数N(<= 10),分别是正确的密码和系统允许尝试的次数。随后每行给出一个以回车结束的非空字符串,是用户尝试输入的密码。输入保证至少有一次尝试。当读到一行只有单个#字符时,输入结束,并且这一行不是用户的输入。

输出格式:

对用户的每个输入,如果是正确的密码且尝试次数不超过N,则在一行中输出“Welcome in”,并结束程序;如果是错误的,则在一行中按格式输出“Wrong password: 用户输入的错误密码”;当错误尝试达到N次时,再输出一行“Account locked”,并结束程序。输入样例1:Correct%pw 3

correct%pw

Correct@PW

whatisthepassword!

Correct%pw

#输出样例1:Wrong password: correct%pw

Wrong password: Correct@PW

Wrong password: whatisthepassword!

Account locked输入样例2:cool@gplt 3

coolman@gplt

coollady@gplt

cool@gplt

try again

#输出样例2:Wrong password: coolman@gplt

Wrong password: coollady@gplt

Welcome inJava代码如下:

import java.util.Scanner;

public class Main {

public static void main(String[] args) {

Scanner input = new Scanner(System.in);

String realpwd = input.next();

int times = input.nextInt();

input.nextLine();

int trytime = 0;

while (true) {

String trypwd = input.nextLine();

if (trypwd.equals("#")) {

break;

} else if (trytime >= times) {

System.out.println("Account locked");

break;

} else if (trypwd.equals(realpwd)) {

System.out.println("Welcome in");

break;

} else if (!trypwd.equals(realpwd)) {

System.out.println("Wrong password: " + trypwd);

trytime++;

}

}

input.close();

}

}

这题要注意的点是比较两个字符串是否相等用的是string.equals(str);而不是==!!!刚开始就用错了,看了半天!

再有就是只有判断的条件有直接退出的就放前面去!

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值