hdu1018(求n!的位数)



Problem Description
In many applications very large integers numbers are required. Some of these applications are using keys for secure transmission of data, encryption, etc. In this problem you are given a number, you have to determine the number of digits in the factorial of the number.
 

Input
Input consists of several lines of integer numbers. The first line contains an integer n, which is the number of cases to be tested, followed by n lines, one integer 1 ≤ n ≤ 10 7 on each line.
 

Output
The output contains the number of digits in the factorial of the integers appearing in the input.
 

Sample Input
 
  
2 10 20
 

Sample Output
 
  
7 19


题意读懂了之后就是求位数的题目嘛,求一个数n的位数很容易联想到(int)log10(n)+1,现在变成了n的阶乘,恰好又log里面相乘,直接变相加呀!这种水题不造为毛会在亚洲赛出现。。。。

貌似还有一种方法是套公式,斯特林公式:lnN!=NlnN-N+0.5*ln(2*N*pi)。

#include <iostream>
#include <stdio.h>
#include<string.h>
#include<math.h>
using namespace std;
int main()
{
    int n,t;scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        double s=0;
        for(int i=1;i<=n;i++)
            s+=log10(i);
        printf("%d\n",(int)s+1);
    }
    return 0;
}

转载于:https://www.cnblogs.com/martinue/p/5490510.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值