2016 ACM/ICPC Asia Regional Qingdao Online 1002 Cure

题目链接:

http://acm.hdu.edu.cn/showproblem.php?pid=5879



Problem Description
Given an integer n , we only want to know the sum of 1/k2 where k from 1 to n .
 

 

Input
There are multiple cases.
For each test case, there is a single line, containing a single positive integer n .
The input file is at most 1M.
 

 

Output
The required sum, rounded to the fifth digits after the decimal point.
 

 

Sample Input
1
2
4
8
15
 

 

Sample Output
1.00000
1.25000
1.42361
1.52742
1.58044
 
Hint:
题意:

n,求 ∑k=1n1k2\sum_{k=1}^{n}\frac{1}{k^2}k=1n​​k2​​1​​

题解:

n很大的时候答案趋近于π26\frac{\pi^2}{6}6π2​​​​nnn 小的时候预处理即可。

其实可以直接暴力直接打表过,但是自己当时比较2,没想到,直接用了大数的相加。还有就是前导0自己忘记考虑了,哎,自己要做的事情还有很多啊。

代码:

#include <cmath>
#include <cstdio>
#include <iostream>
#include <cstring>
#include <algorithm>
using namespace std;
const int maxn = 1e6;
#define met(a,b) memset(a,b,sizeof(a))
#define pi acos(-1.0)
char s[maxn+1000];
double num[maxn];
int main()
{
    met(num,0);
    num[1]=1;
    for(int i=2;i<=maxn;i++)
        num[i]=num[i-1]+1.0/i/i;
    while(scanf("%s",s)!=EOF)
    {
        int cnt=0;
        int l=strlen(s);
        int l1=l;
        while(s[cnt]=='0'||cnt==l)
            cnt++;
        l-=cnt;
        if(l>6)
            printf("%.5lf\n",pi*pi/6.0);
        else
        {
          int sum=0;
          for(int i=0;i<l1;i++)
              sum=sum*10+s[i]-'0';
          if(sum>maxn)
            printf("%.5lf\n",pi*pi/6.0);
          else
            printf("%.5lf\n",num[sum]);
        }
    }
}

  

 

转载于:https://www.cnblogs.com/TAT1122/p/5879505.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值