首字母变大写

Problem Description
输入一个英文句子,将每个单词的第一个字母改成大写字母。
 


 

Input
输入数据包含多个测试实例,每个测试实例是一个长度不超过100的英文句子,占一行。
 


 

Output
请输出按照要求改写后的英文句子。
 


 

Sample Input
i like acm i want to get an accepted
 


 

Sample Output
I Like Acm I Want To Get An Accepted

 

 

#include<stdio.h>
#include<string.h>
int main()
{
    char str[1000], max;
    int i, a, t;
    while( gets( str ) )
    {
           t = strlen( str );
           max = str[0];
          for( i = 0; i < t; i++ )
             {
                 if( max < str[i] )
                  
                         max = str[i];
                  }
             }
         for( i = 0; i < t; i++ )
         {
            printf( "%c", str[i] );
            
            if( str[i]==max )printf( "(max)" );
        }
         puts( "" );    
    }
    return 0;
}

转载于:https://www.cnblogs.com/zsj576637357/archive/2011/11/16/2250522.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值