hdu1469

                                                                                                  COURSES
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 15394 Accepted: 6082

Description

Consider a group of N students and P courses. Each student visits zero, one or more than one courses. Your task is to determine whether it is possible to form a committee of exactly P students that satisfies simultaneously the conditions: 

  • every student in the committee represents a different course (a student can represent a course if he/she visits that course) 
  • each course has a representative in the committee 

Input

Your program should read sets of data from the std input. The first line of the input contains the number of the data sets. Each data set is presented in the following format: 

P N 
Count1 Student 1 1 Student 1 2 ... Student 1 Count1 
Count2 Student 2 1 Student 2 2 ... Student 2 Count2 
... 
CountP Student P 1 Student P 2 ... Student P CountP 

The first line in each data set contains two positive integers separated by one blank: P (1 <= P <= 100) - the number of courses and N (1 <= N <= 300) - the number of students. The next P lines describe in sequence of the courses �from course 1 to course P, each line describing a course. The description of course i is a line that starts with an integer Count i (0 <= Count i <= N) representing the number of students visiting course i. Next, after a blank, you抣l find the Count i students, visiting the course, each two consecutive separated by one blank. Students are numbered with the positive integers from 1 to N. 
There are no blank lines between consecutive sets of data. Input data are correct. 

Output

The result of the program is on the standard output. For each input data set the program prints on a single line "YES" if it is possible to form a committee and "NO" otherwise. There should not be any leading blanks at the start of the line.

Sample Input

2
3 3
3 1 2 3
2 1 2
1 1
3 3
2 1 3
2 1 3
1 1

Sample Output

YES
NO


/*poj 1469课程 请用scanf
    数据范围好像有错
*/
#include<iostream>
using namespace std;
const int N = 305; //学生数
const int P = 105; //课程数   
int NUM;           //前向星变量
int head[N];       //前向星表头
int match_x[N];    //学生有没有被匹配
int match_y[N];    //课程有没有被匹配
bool mark_y[N];    //课程在找增广路时有没有被访问过

struct Node{
    int u,v,next; 
}node[N*P]; //N个学生,没个P门课

void add(int a,int b){ //前向星添加边
    node[NUM].u = a;
    node[NUM].v = b;
    node[NUM].next = head[a];
    head[a] = NUM++;
}

bool path(int u){
    for(int i=head[u]; ~i ;i=node[i].next){  //枚举每个能和u匹配的点
        int v = node[i].v;                   //匹配的点v
        if(mark_y[v] == false){              //如果本轮搜索没被标记过
            mark_y[v] = true;                //标记为搜索过
            if(match_y[v]==-1 || path(match_y[v])){//如果没有匹配 或 找到增广路
                match_x[u] = v;              //点u标记为v匹配
                match_y[v] = u;              //点v标记为跟u
                return true;                 //返回1
            }
        }
    }
    return false;                            //匹配不到返回0
}

int slove(int n){
    memset(match_x,255,sizeof(match_x));    //初始化,-1表示没有匹配到
    memset(match_y,255,sizeof(match_y));
    int result = 0;                         //答案 
    for(int i=1;i<=n;i++){                  //枚举没个X集合的点(学生)
        if(match_x[i] == -1){               //如果该学生没匹配过
            memset(mark_y,false,sizeof(mark_y)); //进行匹配
            result += path(i);              //结果加匹配结果
        }
    }
    return result;                         //返回输出
}

int main(){
    int t,n,p,m,to;
    while(scanf("%d",&t)!=EOF){
        while(t--){
            memset(head,255,sizeof(head));    //初始化连表头
            NUM = 0;                          //初始化边数
            scanf("%d%d",&p,&n);
            for(int i=1;i<=p;i++){            //第i个学生跟m门课程匹配
                scanf("%d",&m);
                while(m--){                   //通过前向星添加变
                    scanf("%d",&to);
                    add(i,to);
                }
            }
            if(p==slove(n)) printf("YES\n"); //若每个学生都能做课代表(完美匹配)
            else printf("NO\n");             
        }
    }
    return 0;
}

 

 

不用前向星做:

#include <cstdio>
#include <cstring>
#define M 301

int P, N;   //课程数; 学生数
bool course[M][M], used[M]; 
int match[M]; 

bool DFS( int k )    //DFS增广
{
    int i, temp; 
    for( i = 1; i <= N; i++ )
    {
        if( course[k][i] && !used[i] )
        {
            used[i] = 1; 
            temp = match[i];  match[i] = k; 
            if( temp == -1 || DFS( temp ) ) 
                return 1; 
            match[i] = temp; 
        }
    }
    return 0; 
}

int MaxMatch()    //求二部图最大匹配
{
    int i, MatchNum = 0; 
    memset( match, -1, sizeof( match ) ); 
    for( i = 1; i <= P; i++ )
    {
        memset( used, 0, sizeof( used ) ); 
        if( DFS( i ) ) MatchNum++; //累加匹配数
        if( MatchNum == P ) break; 
    }
    return MatchNum;    //返回最大匹配数
}

int main( )
{
    int i, j, num, t, n; 
    scanf( "%d", &n ); 
    while( n-- )
    {
        scanf( "%d%d", &P, &N );    //读入数据
        memset( course, 0, sizeof( course ) ); 
        for( i = 1; i <= P; i++ )
        {
            scanf( "%d", &num ); 
            for( j = 0; j < num; j++ )
            {
                scanf( "%d", &t ); 
                course[i][t] = 1; 
            }
        }
        //如果匹配数与课程数相等,则可以组成委员会
        if( MaxMatch() == P ) printf( "YES\n" ); 
        else printf( "NO\n" ); 
    }
    return 0; 
}

 

转载于:https://www.cnblogs.com/Deng1185246160/p/3236356.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
资源包主要包含以下内容: ASP项目源码:每个资源包中都包含完整的ASP项目源码,这些源码采用了经典的ASP技术开发,结构清晰、注释详细,帮助用户轻松理解整个项目的逻辑和实现方式。通过这些源码,用户可以学习到ASP的基本语法、服务器端脚本编写方法、数据库操作、用户权限管理等关键技术。 数据库设计文件:为了方便用户更好地理解系统的后台逻辑,每个项目中都附带了完整的数据库设计文件。这些文件通常包括数据库结构图、数据表设计文档,以及示例数据SQL脚本。用户可以通过这些文件快速搭建项目所需的数据库环境,并了解各个数据表之间的关系和作用。 详细的开发文档:每个资源包都附有详细的开发文档,文档内容包括项目背景介绍、功能模块说明、系统流程图、用户界面设计以及关键代码解析等。这些文档为用户提供了深入的学习材料,使得即便是从零开始的开发者也能逐步掌握项目开发的全过程。 项目演示与使用指南:为帮助用户更好地理解和使用这些ASP项目,每个资源包中都包含项目的演示文件和使用指南。演示文件通常以视频或图文形式展示项目的主要功能和操作流程,使用指南则详细说明了如何配置开发环境、部署项目以及常见问题的解决方法。 毕业设计参考:对于正在准备毕业设计的学生来说,这些资源包是绝佳的参考材料。每个项目不仅功能完善、结构清晰,还符合常见的毕业设计要求和标准。通过这些项目,学生可以学习到如何从零开始构建一个完整的Web系统,并积累丰富的项目经验。
资源包主要包含以下内容: ASP项目源码:每个资源包中都包含完整的ASP项目源码,这些源码采用了经典的ASP技术开发,结构清晰、注释详细,帮助用户轻松理解整个项目的逻辑和实现方式。通过这些源码,用户可以学习到ASP的基本语法、服务器端脚本编写方法、数据库操作、用户权限管理等关键技术。 数据库设计文件:为了方便用户更好地理解系统的后台逻辑,每个项目中都附带了完整的数据库设计文件。这些文件通常包括数据库结构图、数据表设计文档,以及示例数据SQL脚本。用户可以通过这些文件快速搭建项目所需的数据库环境,并了解各个数据表之间的关系和作用。 详细的开发文档:每个资源包都附有详细的开发文档,文档内容包括项目背景介绍、功能模块说明、系统流程图、用户界面设计以及关键代码解析等。这些文档为用户提供了深入的学习材料,使得即便是从零开始的开发者也能逐步掌握项目开发的全过程。 项目演示与使用指南:为帮助用户更好地理解和使用这些ASP项目,每个资源包中都包含项目的演示文件和使用指南。演示文件通常以视频或图文形式展示项目的主要功能和操作流程,使用指南则详细说明了如何配置开发环境、部署项目以及常见问题的解决方法。 毕业设计参考:对于正在准备毕业设计的学生来说,这些资源包是绝佳的参考材料。每个项目不仅功能完善、结构清晰,还符合常见的毕业设计要求和标准。通过这些项目,学生可以学习到如何从零开始构建一个完整的Web系统,并积累丰富的项目经验。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值