动态规划——E (LIS())最长上升子序列

E - LIS
Time Limit:1000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u
Submit  Status

Description

The world financial crisis is quite a subject. Some people are more relaxed while others are quite anxious. John is one of them. He is very concerned about the evolution of the stock exchange. He follows stock prices every day looking for rising trends. Given a sequence of numbers p1, p2,...,pn representing stock prices, a rising trend is a subsequence pi1 < pi2 < ... < pik, with i1 < i2 < ... < ik. John’s problem is to find very quickly the longest rising trend.

Input

Each data set in the file stands for a particular set of stock prices. A data set starts with the length L (L ≤ 100000) of the sequence of numbers, followed by the numbers (a number fits a long integer). 
White spaces can occur freely in the input. The input data are correct and terminate with an end of file.

Output

The program prints the length of the longest rising trend. 
For each set of data the program prints the result to the standard output from the beginning of a line.

Sample Input

6 
5 2 1 4 5 3 
3  
1 1 1 
4 
4 3 2 1

Sample Output

3 
1 
1

Hint

There are three data sets. In the first case, the length L of the sequence is 6. The sequence is 5, 2, 1, 4, 5, 3. The result for the data set is the length of the longest rising trend: 3.
解题思路:这个题目是一个求最长递增子序列问题,找一个数组存输入的最大升序,然后它的长度就是我们需要输出的答案需,要用二分忧化法做,
我们的问题是要如何找到最大升序数组?这里可以分成两步:1.判断当前数字时候大于前一数字,若是:把它放在数组后面, 否则: 通过2分法,判断它的大小应该放的位置即可。
程序代码:
#include <cstdio>
using namespace std;
const int L=100010;
int a[L],b[L];
int n;
void init()
{
    for(int i=0;i<n;i++)
        scanf("%d",&a[i]);
}
int  bin(int r,int k)
{
    int l=1;
    while(l<=r)
       {
        int mid=(l+r)/2;
        if(k>b[mid])
            l=mid+1;
        else
            r=mid-1;
       }
    return l;
}
int  work()
{
    int i,j,k;
    int c=0;
    for(i=0;i<n;i++)
    if(c==0||a[i]>b[c])
        b[++c]=a[i];
    else
    {
        k=bin(c,a[i]);
        b[k]=a[i];
    }
    return c;
}
int main()
{
     while(scanf("%d",&n)==1)
    {
       init();
       printf("%d\n",work());
    }
    return 0;
}
View Code

 

转载于:https://www.cnblogs.com/www-cnxcy-com/p/4734904.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值