Problem 2221 RunningMan(fuzoj)

 Problem 2221 RunningMan

Accept: 130    Submit: 404
Time Limit: 1000 mSec    Memory Limit : 32768 KB

 Problem Description

ZB loves watching RunningMan! There's a game in RunningMan called 100 vs 100.

There are two teams, each of many people. There are 3 rounds of fighting, in each round the two teams send some people to fight. In each round, whichever team sends more people wins, and if the two teams send the same amount of people, RunningMan team wins. Each person can be sent out to only one round. The team wins 2 rounds win the whole game. Note, the arrangement of the fighter in three rounds must be decided before the whole game starts.

We know that there are N people on the RunningMan team, and that there are M people on the opposite team. Now zb wants to know whether there exists an arrangement of people for the RunningMan team so that they can always win, no matter how the opposite team arrange their people.

 Input

The first line contains an integer T, meaning the number of the cases. 1 <= T <= 50.

For each test case, there's one line consists of two integers N and M. (1 <= N, M <= 10^9).

 Output

For each test case, Output "Yes" if there exists an arrangement of people so that the RunningMan team can always win. "No" if there isn't such an arrangement. (Without the quotation marks.)

 Sample Input

2 100 100 200 100

 Sample Output

No Yes

 思路:贪心.

因为总共就分三个队,因为两个队都要选取最优的策略,不论B队咋放,要使A队赢 。

设A队N人,B队M人。 

设A第一次排a人,如果B这次要赢,根据最优就派(a+1)人,所以A下两场必需赢就可以得到(N-a)/2>=(M-a-1);因为B队已经赢了一次所以,可以把剩下的都放在一个队上。

假如B这次选择输,那他就在这次不派人,那么在下两场中A必须在赢一次,那么A只要在一次中派出所有剩下的人(N-a),因为还有一场A没有派人,所以B要会在那派上1人,

所以A要赢就有(N-a)>=M-1;这样两个不等式同时成立可以得(N+1>=3*M/2) 

  1 1 //############

 2    2 #include<stdio.h>
 3   3 #include<algorithm>
 4   4 #include< string.h>
 5   5 #include<stdlib.h>
 6   6 #include<math.h>
 7   7 #include<iostream>
 8   8 #include<cstdio>
 9   9  #define sc(x) scanf("%I64d",&x)
10  10  #define pr(x) printf("%I64d",x)
11  11  #define prr(x) printf(" %I64d",x)
12  12  #define prrr(x) printf("%I64d\n",x)
13  13 typedef  long  long ll;
14  14  const ll N=1e9+ 7;
15  15 ll aa[ 5];
16  16 ll bb[ 5];
17  17  using  namespace std ;
18  18  int main( void)
19  19 {
20  20     ll i,j,k,p,q;
21  21     sc(k);
22  22      while(k--)
23  23     {
24  24         sc(p);
25  25         sc(q);
26  26          if((p+ 1)<q* 3/ 2)
27  27         {
28  28             printf( " No\n ");
29  29         }
30  30          else
31  31         {
32  32             printf( " Yes\n ");
33  33         }
34  34     }
35  35      return  0;
36  36 }
37  
38  

 

 

 

  2###

 2 #include<stdio.h>
 3 #include<algorithm>
 4 #include< string.h>
 5 #include<stdlib.h>
 6 #include<math.h>
 7 #include<iostream>
 8 #include<cstdio>
 9  #define sc(x) scanf("%I64d",&x)
10  #define pr(x) printf("%I64d",x)
11  #define prr(x) printf(" %I64d",x)
12  #define prrr(x) printf("%I64d\n",x)
13 typedef  long  long ll;
14  const ll N=1e9+ 7;
15 ll aa[ 5];
16 ll bb[ 5];
17  using  namespace std ;
18  int main( void)
19 {
20     ll i,j,k,p,q;
21     sc(k);
22      while(k--)
23     {
24         sc(p);
25         sc(q);
26         ll mm=p/ 3;
27         ll nn=q/ 2;
28         aa[ 0]=mm;
29         ll ss=p-mm;
30          if(ss% 2== 0)
31         {
32             aa[ 1]=ss/ 2;
33             aa[ 2]=ss/ 2;
34         }
35          else
36         {
37             aa[ 1]=ss/ 2;
38             aa[ 2]=ss/ 2+ 1;
39         }
40         sort(aa,aa+ 3);
41          if(nn>aa[ 0]&&nn>aa[ 1])
42         {
43             printf( " No\n ");
44         }
45          else
46         {
47             printf( " Yes\n ");
48         }
49     }
50      return  0;
51 }


转载于:https://www.cnblogs.com/zzuli2sjy/p/5180243.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
东南亚位于我国倡导推进的“一带一路”海陆交汇地带,作为当今全球发展最为迅速的地区之一,近年来区域内生产总值实现了显著且稳定的增长。根据东盟主要经济体公布的最新数据,印度尼西亚2023年国内生产总值(GDP)增长5.05%;越南2023年经济增长5.05%;马来西亚2023年经济增速为3.7%;泰国2023年经济增长1.9%;新加坡2023年经济增长1.1%;柬埔寨2023年经济增速预计为5.6%。 东盟国家在“一带一路”沿线国家中的总体GDP经济规模、贸易总额与国外直接投资均为最大,因此有着举足轻重的地位和作用。当前,东盟与中国已互相成为双方最大的交易伙伴。中国-东盟贸易总额已从2013年的443亿元增长至 2023年合计超逾6.4万亿元,占中国外贸总值的15.4%。在过去20余年中,东盟国家不断在全球多变的格局里面临挑战并寻求机遇。2023东盟国家主要经济体受到国内消费、国外投资、货币政策、旅游业复苏、和大宗商品出口价企稳等方面的提振,经济显现出稳步增长态势和强韧性的潜能。 本调研报告旨在深度挖掘东南亚市场的增长潜力与发展机会,分析东南亚市场竞争态势、销售模式、客户偏好、整体市场营商环境,为国内企业出海开展业务提供客观参考意见。 本文核心内容: 市场空间:全球行业市场空间、东南亚市场发展空间。 竞争态势:全球份额,东南亚市场企业份额。 销售模式:东南亚市场销售模式、本地代理商 客户情况:东南亚本地客户及偏好分析 营商环境:东南亚营商环境分析 本文纳入的企业包括国外及印尼本土企业,以及相关上下游企业等,部分名单 QYResearch是全球知名的大型咨询公司,行业涵盖各高科技行业产业链细分市场,横跨如半导体产业链(半导体设备及零部件、半导体材料、集成电路、制造、封测、分立器件、传感器、光电器件)、光伏产业链(设备、硅料/硅片、电池片、组件、辅料支架、逆变器、电站终端)、新能源汽车产业链(动力电池及材料、电驱电控、汽车半导体/电子、整车、充电桩)、通信产业链(通信系统设备、终端设备、电子元器件、射频前端、光模块、4G/5G/6G、宽带、IoT、数字经济、AI)、先进材料产业链(金属材料、高分子材料、陶瓷材料、纳米材料等)、机械制造产业链(数控机床、工程机械、电气机械、3C自动化、工业机器人、激光、工控、无人机)、食品药品、医疗器械、农业等。邮箱:market@qyresearch.com

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值