poj2823 Sliding Window

Description

An array of size  n ≤ 10 6 is given to you. There is a sliding window of size  k which is moving from the very left of the array to the very right. You can only see the  k numbers in the window. Each time the sliding window moves rightwards by one position. Following is an example: 
The array is  [1 3 -1 -3 5 3 6 7], and  k is 3.
Window positionMinimum valueMaximum value
[1  3  -1] -3  5  3  6  7 -13
 1 [3  -1  -3] 5  3  6  7 -33
 1  3 [-1  -3  5] 3  6  7 -35
 1  3  -1 [-3  5  3] 6  7 -35
 1  3  -1  -3 [5  3  6] 7 36
 1  3  -1  -3  5 [3  6  7]37

Your task is to determine the maximum and minimum values in the sliding window at each position. 

Input

The input consists of two lines. The first line contains two integers  n and  k which are the lengths of the array and the sliding window. There are  n integers in the second line. 

Output

There are two lines in the output. The first line gives the minimum values in the window at each position, from left to right, respectively. The second line gives the maximum values. 

Sample Input

8 3
1 3 -1 -3 5 3 6 7

Sample Output

-1 -3 -3 -3 3 3

3 3 5 5 6 7

一开始这题用线段树做,后来用单调队列试了一下。单调队列的思想是用数组模拟一个队列,队列中的元素满足从队伍的头到尾元素大小单调递增或递减(注意:这里是严格递增或递减,即没有相同的,因为如果有两个相同的元素,后面的元素进队的时间一定小于前面一个元素,可以用后面的元素代替,所以前面的无意义),也满足从队伍的头到尾元素进队时间单调递增或递减,每次进入一个元素,从后面开始找,一直找到大于或者小于这个数为止,后面的元素全部删除。

#include<iostream>
#include<stdio.h>
#include<string.h>
#include<math.h>
#include<algorithm>
#include<map>
#include<string>
using namespace std;
#define maxn 1000005
int a[maxn],num1[maxn],num2[maxn];
int q1[1111111][2];
int q2[1111111][2];
int main()
{
	int n,k,i,j,front1,rear1,front2,rear2;
	while(scanf("%d%d",&n,&k)!=EOF)
	{
		for(i=1;i<=n;i++)scanf("%d",&a[i]);
		front1=front2=1;rear1=rear2=0;
		for(i=1;i<=k-1;i++){            //单调递增 ,得到最小值 
			while(front2<=rear2 && q2[rear2][0]>=a[i]){
				rear2--;
			}
			rear2++;
			q2[rear2][0]=a[i];q2[rear2][1]=i;
		}
		for(i=k;i<=n;i++){
			while(front2<=rear2 && q2[rear2][0]>=a[i]){
				rear2--;
			}
			rear2++;
			q2[rear2][0]=a[i];q2[rear2][1]=i;
			while(q2[front2][1]+k-1<i)front2++;
			num2[i]=q2[front2][0];
			if(i==n)printf("%d\n",num2[n]);
			else printf("%d ",num2[i]);
		}
		
		
		
		
		
		for(i=1;i<=k-1;i++){            //单调递减 ,得到最大值 
			while(front1<=rear1 && q1[rear1][0]<=a[i]){
				rear1--;
			}
			rear1++;
			q1[rear1][0]=a[i];q1[rear1][1]=i;
		}
		for(i=k;i<=n;i++){
			while(front1<=rear1 && q1[rear1][0]<=a[i]){
				rear1--;
			}
			rear1++;
			q1[rear1][0]=a[i];q1[rear1][1]=i;
			while(q1[front1][1]+k-1<i)front1++;
			num1[i]=q1[front1][0];
			if(i==n)printf("%d\n",num1[n]);
			else printf("%d ",num1[i]);
		}
		
		
	}
	return 0;
}


转载于:https://www.cnblogs.com/herumw/p/9464800.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值