SPOJ694Distinct Substrings&&SPOJ705New Distinct Substrings

 

Given a string, we need to find the total number of its distinct substrings.

Input

T- number of test cases. T<=20;
Each test case consists of one string, whose length is <= 1000

Output

For each test case output one number saying the number of distinct substrings.

Example

Sample Input:
2
CCCCC
ABABA

Sample Output:
5
9

Explanation for the testcase with string ABABA:
len=1 : A,B
len=2 : AB,BA
len=3 : ABA,BAB
len=4 : ABAB,BABA
len=5 : ABABA
Thus, total number of distinct substrings is 9.

另一道的题所改变的只是n<=50000。

题目大意求所有不相同的子串数量

过程:用所有子串数量减去h数组的和即为答案

因为统计是恰好多加了每个后缀的公共前缀

        #include<cstdio>
        #include<cstring>
        const int N=50005;
        int sa[N],wa[N<<1],wb[N<<1],to[N],h[N];
        char sr[N];
        int main()
        {
            int t;
            scanf("%d",&t);
            while(t--)
            {
                scanf("%s",sr);
                int n=strlen(sr),m=128,*x=wa,*y=wb;
                for(int i=0;i<m;++i) to[i]=0;
                for(int i=0;i<n;++i) ++to[x[i]=sr[i]];
                for(int i=1;i<m;++i) to[i]+=to[i-1];
                for(int i=n-1;i>=0;--i) sa[--to[x[i]]]=i;
                for(int j=1,p=0;p<n;m=p,j<<=1)
                {
                    p=0;
                    for(int i=n-j;i<n;++i) y[p++]=i,x[i+j]=-1;
                    for(int i=0;p<n;++i) if(sa[i]>=j) y[p++]=sa[i]-j;
                    for(int i=0;i<m;++i) to[i]=0;
                    for(int i=0;i<n;++i) ++to[x[y[i]]];
                    for(int i=1;i<m;++i) to[i]+=to[i-1];
                    for(int i=n-1;i>=0;--i) sa[--to[x[y[i]]]]=y[i];
                    int *t=x;x=y;y=t;
                    x[sa[0]]=0;
                    for(int i=p=1;i<n;++i)
                        if(y[sa[i]]!=y[sa[i-1]]||y[sa[i]+j]!=y[sa[i-1]+j]) x[sa[i]]=p++;
                        else x[sa[i]]=p-1;
                }
                for(int i=0,j,k=0;i<n;h[x[i++]]=k)
                    if(!x[i]) k=0;
                    else for(k?--k:0,j=sa[x[i]-1];j+k<n&&i+k<n&&sr[j+k]==sr[i+k];++k);
                long long  ans=(long long )(n+1)*n/2; 
                for(int i=1;i<n;++i) ans-=h[i];
                printf("%lld\n",ans);
            }
            return 0;
        }  

转载于:https://www.cnblogs.com/bzmd/p/6388911.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值