HDOJ 1455 Sticks

Sticks

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 3171 Accepted Submission(s): 780


Problem Description
George took sticks of the same length and cut them randomly until all parts became at most 50 units long. Now he wants to return sticks to the original state, but he forgot how many sticks he had originally and how long they were originally. Please help him and design a program which computes the smallest possible original
 length of those sticks. All lengths expressed in units are integers greater than zero.
 


 

Input
The input contains blocks of 2 lines. The first line contains the number of sticks parts after cutting, there are at most 64 sticks. The second line contains the lengths
of those parts separated by the space. The last line of the file contains zero.
 


 

Output
The output file contains the smallest possible length of original sticks, one per line.
 


 

Sample Input
9 5 2 1 5 2 1 5 2 1 4 1 2 3 4 0
 


 

Sample Output
6 5

 

 


#include<iostream>
#include<algorithm>
using namespace std;
int len,num,sum,snum;
int stickslenth[100];
int makt[100]; //用于标记木棍是否被使用
int lim;
bool cmp(const int a,const int b)
{
      return a > b;
}
bool dfs(int lastlen,int b)
{
       int i;
      if( -- lim <= 0)
      return false;
     if(lastlen == 0)//一根木棒已经找出
     {
             i = 0;
             while(i < num && makt[i])
             i++;
             if(i == num)             //当全部的木棍都找出来了的时候则返回真
                   return true;
             makt[i] = true;          //将第i个数据标记为已经访问过
            if(dfs(len - stickslenth[i],i + 1))      //搜索下一根木棍
                      return true;
             makt[i] = false;
             return false;
      }
      int perlen = -1;
      for(i = b; i < num ; ++i)
      {
             if(makt[i] || lastlen < stickslenth[i] || perlen == stickslenth[i])
                     continue;
             makt[i] = true;
             if(dfs(lastlen-stickslenth[i],i+1,t+1))
                      return true;

              makt[i] = false;

              perlen = stickslenth[i];

              if(lastlen == stickslenth[i])
              return false;
        }
      return false;
}

//-------------------------------------------------------------------------------------------------------------
int main()
{
        while( cin >> num , num)
         {
                 sum = 0;
                 for(int i = 0; i < num; i++)
                 {
                        cin >> stickslenth[i];
                       sum += stickslenth[i];
                 }
               sort(stickslenth,stickslenth+num,cmp);
              /*
               for(i = 0; i < num ; i++)
              cout << stickslenth[i] <<  " ";
              cout << endl;
            */
               for(len = stickslenth[0]; len < sum; len++)
               {
                     if(sum % len == 0)//当可以平分为     1156gfddfk;lsdfkl;sdfopksdfsdp[fp[lagsdfksdfdsfsdf
                    {
                              snum = sum/len;
                             memset(makt,false,sizeof(makt));
                            if(dfs(len,0,0))
                                  break;
                     }
              }
              cout << len << endl; 
         }
         return 0;
}

转载于:https://www.cnblogs.com/LUO257316/archive/2012/08/01/3220877.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值