链接:https://www.nowcoder.com/acm/contest/77/A
来源:牛客网
时间限制:C/C++ 2秒,其他语言4秒
空间限制:C/C++ 131072K,其他语言262144K
64bit IO Format: %lld
题目描述
在一个排列中,如果一对数的前后位置与大小顺序相反,即前面的数大于后面的数,那么它们就称为一个逆序。一个排列中逆序的总数就称为这个排列的逆序数。比如一个序列为4 5 1 3 2, 那么这个序列的逆序数为7,逆序对分别为(4, 1), (4, 3), (4, 2), (5, 1), (5, 3), (5, 2),(3, 2)。
输入描述:
第一行有一个整数n(1 <= n <= 100000), 然后第二行跟着n个整数,对于第i个数a[i],(0 <= a[i] <= 100000)。
输出描述:
输出这个序列中的逆序数
c++代码:
#include<bits/stdc++.h>
using namespace std;
const int maxn = 100000+10;
int a[maxn];
int main()
{
memset(a,0,sizeof(a));
int t,n;
long long sum=0;
scanf("%d",&n);
for(int i=0;i<n;i++)
{
scanf("%d",&t);
sum =sum+ a[t];//如果出现了就加上去
for(int j=0;j<t;j++)
a[j]++;//比这个数小的就++,后面可能会用到.
}
printf("%lld\n",sum);
return 0;
}
hdu(1394)——Minimum Inversion Number
Problem Description The inversion number of a given number sequence a1, a2, ..., an is the number of pairs (ai, aj) that satisfy i < j and ai > aj.
Input The input consists of a number of test cases. Each case consists of two lines: the first line contains a positive integer n (n <= 5000); the next line contains a permutation of the n integers from 0 to n-1.
Output For each case, output the minimum inversion number on a single line.
Sample Input 10 1 3 6 9 0 8 5 7 4 2
Sample Output 16 |
求逆序数的最小值
每次可以把第一个放到最后面
AC:
#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<iostream>
using namespace std;
#define maxn 5555
#define inf 99999999
int a[maxn];
int main()
{
int n;
while(~scanf("%d",&n))
{
int min1=inf,num=0;
for(int i=0;i<n;i++)
scanf("%d",&a[i]);
for(int i=0;i<n;i++)
for(int j=i+1;j<n;j++)
if(a[i]>a[j]&&i<j) num++;
if(min1>num) min1=num;
for(int i=0;i<n;i++)///就是每一次把最前面的移到最后,逆序数对数会减少a[i]个,但是会增加n-(a[i]+1)个
{
num=num-a[i]+n-(a[i]+1);
if(min1>num) min1=num;
}
printf("%d\n",min1);
}
}