poj-3264-Balanced Lineup

poj   3264  Balanced Lineup

link: http://poj.org/problem?id=3264

 

 

                                    Balanced Lineup
Time Limit: 5000MS Memory Limit: 65536K
Total Submissions: 48747 Accepted: 22833
Case Time Limit: 2000MS

Description

For the daily milking, Farmer John's N cows (1 ≤ N ≤ 50,000) always line up in the same order. One day Farmer John decides to organize a game of Ultimate Frisbee with some of the cows. To keep things simple, he will take a contiguous range of cows from the milking lineup to play the game. However, for all the cows to have fun they should not differ too much in height.

Farmer John has made a list of Q (1 ≤ Q ≤ 200,000) potential groups of cows and their heights (1 ≤ height ≤ 1,000,000). For each group, he wants your help to determine the difference in height between the shortest and the tallest cow in the group.

Input

Line 1: Two space-separated integers,  N and  Q
Lines 2.. N+1: Line  i+1 contains a single integer that is the height of cow  i 
Lines  N+2.. N+ Q+1: Two integers  A and  B (1 ≤  A ≤  B ≤  N), representing the range of cows from  A to  B inclusive.

Output

Lines 1.. Q: Each line contains a single integer that is a response to a reply and indicates the difference in height between the tallest and shortest cow in the range.

Sample Input

6 3
1
7
3
4
2
5
1 5
4 6
2 2

Sample Output

6
3
0

Source

 

 

题解:

快速找到一个区间[a, b] 之间的最大值和最小值的差;

经典的RMQ问题。 利用Sparse Table算法, 动态规划求解。 

 

#include <iostream> 
#include <cstdio> 
#include <cstring> 
#include <algorithm>
#include <cmath> 
using namespace std; 
const int maxn = 50005; 

int n, m,  num[maxn], dp1[maxn][18], dp2[maxn][18]; 

void BuildIndex(){
	for(int i=0; i<n;++i){
		dp1[i][0] = i; 
		dp2[i][0] = i; 
	} 
	for(int i=1; (1<<i)<=n; ++i){
		for(int j=0; j+(1<<i)-1<n; ++j){
			// find max 
			if(num[dp1[j][i-1]] > num[dp1[j+(1<<(i-1))][i-1]]){
				dp1[j][i] = dp1[j][i-1]; 
			}else{
				dp1[j][i] = dp1[j+(1<<(i-1))][i-1]; 
			}

			// find min
			if(num[dp2[j][i-1]] < num[dp2[j+(1<<(i-1))][i-1]]){
				dp2[j][i] = dp2[j][i-1]; 
			}else{
				dp2[j][i] = dp2[j+(1<<(i-1))][i-1]; 
			}
		}
	}
}

int FindMaxIndex(int start, int end){
	int k = (int)((log((end - start + 1)*1.0))/log(2.0)); 
	if(num[dp1[start][k]] > num[dp1[end-(1<<k)+1][k]]){
		return dp1[start][k]; 
	}else{
		return dp1[end-(1<<k)+1][k]; 
	}
}
int FindMinIndex(int start, int end){
	int k = (int)((log((end - start + 1)*1.0))/log(2.0)); 
	if(num[dp2[start][k]] > num[dp2[end-(1<<k)+1][k]]){
		return dp2[end-(1<<k)+1][k]; 
	}else{
		return dp2[start][k]; 
	}
}

int main(){
	freopen("in.txt", "r", stdin); 

	int ans1, ans2, x, y; 
	while(scanf("%d %d", &n, &m) != EOF){
		for(int i=0; i<n; ++i){
			scanf("%d", &num[i]); 
		}
		BuildIndex(); 
		while(m--){
			scanf("%d %d", &x, &y); 
			if(x > y){ swap(x, y); } 
			ans1 = FindMinIndex(x-1, y-1); 
			ans2 = FindMaxIndex(x-1, y-1); 
			printf("%d\n", (num[ans2] - num[ans1]) );
		}
	}
	return 0; 
}

  

 

转载于:https://www.cnblogs.com/zhang-yd/p/6011270.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值