hdu 4123--Bob’s Race(树形DP+RMQ)

题目链接

 

Problem Description
Bob wants to hold a race to encourage people to do sports. He has got trouble in choosing the route. There are N houses and N - 1 roads in his village. Each road connects two houses, and all houses are connected together. To make the race more interesting, he requires that every participant must start from a different house and run AS FAR AS POSSIBLE without passing a road more than once. The distance difference between the one who runs the longest distance and the one who runs the shortest distance is called “race difference” by Bob. Bob does not want the “race difference”to be more than Q. The houses are numbered from 1 to N. Bob wants that the No. of all starting house must be consecutive. He is now asking you for help. He wants to know the maximum number of starting houses he can choose, by other words, the maximum number of people who can take part in his race.
 

 

Input
There are several test cases.
The first line of each test case contains two integers N and M. N is the number of houses, M is the number of queries.
The following N-1 lines, each contains three integers, x, y and z, indicating that there is a road of length z connecting house x and house y.
The following M lines are the queries. Each line contains an integer Q, asking that at most how many people can take part in Bob’s race according to the above mentioned rules and under the condition that the“race difference”is no more than Q. 

The input ends with N = 0 and M = 0.

(N<=50000 M<=500 1<=x,y<=N 0<=z<=5000 Q<=10000000)
 

 

Output
For each test case, you should output the answer in a line for each query.
 

 

Sample Input
5 5
1 2 3
2 3 4
4 5 3
3 4 2
1
2
3
4
5
0 0
 

 

Sample Output
1
3
3
3
5
 
 
题意:有一颗树有n个节点编号从1~n,这n-1条边都有一个边权表示两点之间的距离,现在要求出从每个点出发不重复经过同一条边能到达的最远距离,然后m次询问,每次输入一个Q,求从连续编号的起点出发达到最远距离之间的最大值和最小值之差小于等于Q的最大区间长?
 
思路:用前向星建树(定1号节点为根节点),一次搜索求出所有节点 以当前节点为根节点时到达子树叶子节点的最远距离和次远距离,然后再进行一次搜索求出每个节点能到达的最远距离(可能是到孩子叶子节点,也可能是经过父亲节点而来的叶子节点),最后用RMQ中的ST算法配合尺取求出满足条件的最大区间长。
 
注意:使用ST算法,查询时不要使用函数log2(x),这个很费时间,自己求就行;另外可以优化一下尺取。
 
代码如下:
#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cstring>
using namespace std;
typedef long long LL;
const int N=50005;
int h[N],H[N],H2[N],ans[N],tot;
int f1[N][20],f2[N][20];
struct edge
{
    int to;
    int next;
    int x;
}e[2*N];

void add(int u,int v,int x)
{
    e[tot].to=v;
    e[tot].x=x;
    e[tot].next=h[u];
    h[u]=tot++;

    e[tot].to=u;
    e[tot].x=x;
    e[tot].next=h[v];
    h[v]=tot++;
}
void getH(int id,int fa)
{
    H[id]=0;
    H2[id]=0;
    for(int i=h[id];i!=-1;i=e[i].next)
    {
        if(e[i].to==fa) continue;
        getH(e[i].to,id);
        int tmp=H[e[i].to]+e[i].x;
        if(H[id]<tmp)
        {
            H2[id]=H[id];
            H[id]=tmp;
        }
        else if(H2[id]<tmp) H2[id]=tmp;
    }
}
void dfs(int id,int fa,int deep)
{
    ans[id]=max(deep,H[id]);
    for(int i=h[id];i!=-1;i=e[i].next)
    {
        if(e[i].to==fa) continue;
        int tmp=deep;
        int d=H[e[i].to]+e[i].x;
        if(d==H[id]) tmp=max(tmp,H2[id]);
        else tmp=max(tmp,H[id]);
        dfs(e[i].to,id,tmp+e[i].x);
    }
}
void cal(int n)
{
   for(int i=1;i<=n;i++) f1[i][0]=ans[i],f2[i][0]=ans[i];
   int len=2;
   for(int s=1;len<=n;s++,len*=2)
   {
       for(int i=1;i+len-1<=n;i++)
       {
           f1[i][s]=max(f1[i][s-1],f1[i+len/2][s-1]);
           f2[i][s]=min(f2[i][s-1],f2[i+len/2][s-1]);
       }
   }
}
int get(int i,int j)
{
    int len=-1;
    int t=j-i+1;
    while(t)
    {
        len++;
        t>>=1;
    }
    return max(f1[i][len],f1[j-(1<<len)+1][len])-min(f2[i][len],f2[j-(1<<len)+1][len]);
}

void init()
{
    tot=0;
    memset(h,-1,sizeof(h));
}
int main()
{
    int n,m;
    while(scanf("%d%d",&n,&m)&&(n+m))
    {
        init();
        for(int i=1;i<n;i++)
        {
            int u,v,x;
            scanf("%d%d%d",&u,&v,&x);
            add(u,v,x);
        }
        getH(1,-1);
        dfs(1,-1,0);
        cal(n);
        while(m--)
        {
            int Q; scanf("%d",&Q);
            int res=0;
            int pos=1;
            for(int i=1;i<=n;i++)
            {
                if(i-pos+1<=res) continue;  ///优化一下;
                int tmp=get(pos,i);
                while(tmp>Q)
                {
                    pos++;
                    tmp=get(pos,i);
                }
                res=max(res,i-pos+1);
            }
            printf("%d\n",res);
        }
    }
    return 0;
}
/**
4 6
1 2 2
1 3 4
3 4 3
*/

/**
18 7984
1 2 2
1 3 4
1 4 3
1 5 5

2 6 1
2 7 3
2 8 7
3 9 2
3 10 4
4 11 2
4 12 2
5 13 3
5 14 3
9 15 7
9 16 6
12 17 5
14 18 4
*/

 

 

转载于:https://www.cnblogs.com/chen9510/p/7627028.html

以下是对提供的参考资料的总结,按照要求结构化多个要点分条输出: 4G/5G无线网络优化与网规案例分析: NSA站点下终端掉4G问题:部分用户反馈NSA终端频繁掉4G,主要因终端主动发起SCGfail导致。分析显示,在信号较好的环境下,终端可能因节能、过热保护等原因主动释放连接。解决方案建议终端侧进行分析处理,尝试关闭节电开关等。 RSSI算法识别天馈遮挡:通过计算RSSI平均值及差值识别天馈遮挡,差值大于3dB则认定有遮挡。不同设备分组规则不同,如64T和32T。此方法可有效帮助现场人员识别因环境变化引起的网络问题。 5G 160M组网小区CA不生效:某5G站点开启100M+60M CA功能后,测试发现UE无法正常使用CA功能。问题原因在于CA频点集标识配置错误,修正后测试正常。 5G网络优化与策略: CCE映射方式优化:针对诺基亚站点覆盖农村区域,通过优化CCE资源映射方式(交织、非交织),提升RRC连接建立成功率和无线接通率。非交织方式相比交织方式有显著提升。 5G AAU两扇区组网:与三扇区组网相比,AAU两扇区组网在RSRP、SINR、下载速率和上传速率上表现不同,需根据具体场景选择适合的组网方式。 5G语音解决方案:包括沿用4G语音解决方案、EPS Fallback方案和VoNR方案。不同方案适用于不同的5G组网策略,如NSA和SA,并影响语音连续性和网络覆盖。 4G网络优化与资源利用: 4G室分设备利旧:面对4G网络投资压减与资源需求矛盾,提出利旧多维度调优策略,包括资源整合、统筹调配既有资源,以满足新增需求和提质增效。 宏站RRU设备1托N射灯:针对5G深度覆盖需求,研究使用宏站AAU结合1托N射灯方案,快速便捷地开通5G站点,提升深度覆盖能力。 基站与流程管理: 爱立信LTE基站邻区添加流程:未提供具体内容,但通常涉及邻区规划、参数配置、测试验证等步骤,以确保基站间顺畅切换和覆盖连续性。 网络规划与策略: 新高铁跨海大桥覆盖方案试点:虽未提供详细内容,但可推测涉及高铁跨海大桥区域的4G/5G网络覆盖规划,需考虑信号穿透、移动性管理、网络容量等因素。 总结: 提供的参考资料涵盖了4G/5G无线网络优化、网规案例分析、网络优化策略、资源利用、基站管理等多个方面。 通过具体案例分析,展示了无线网络优化中的常见问题及解决方案,如NSA终端掉4G、RSSI识别天馈遮挡、CA不生效等。 强调了5G网络优化与策略的重要性,包括CCE映射方式优化、5G语音解决方案、AAU扇区组网选择等。 提出了4G网络优化与资源利用的策略,如室分设备利旧、宏站RRU设备1托N射灯等。 基站与流程管理方面,提到了爱立信LTE基站邻区添加流程,但未给出具体细节。 新高铁跨海大桥覆盖方案试点展示了特殊场景下的网络规划需求。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值