POJ1013称硬币【枚举】

Counterfeit Dollar
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 52474 Accepted: 16402

Description

Sally Jones has a dozen Voyageur silver dollars. However, only eleven of the coins are true silver dollars; one coin is counterfeit even though its color and size make it indistinguishable from the real silver dollars. The counterfeit coin has a different weight from the other coins but Sally does not know if it is heavier or lighter than the real coins.
Happily, Sally has a friend who loans her a very accurate balance scale. The friend will permit Sally three weighings to find the counterfeit coin. For instance, if Sally weighs two coins against each other and the scales balance then she knows these two coins are true. Now if Sally weighs
one of the true coins against a third coin and the scales do not balance then Sally knows the third coin is counterfeit and she can tell whether it is light or heavy depending on whether the balance on which it is placed goes up or down, respectively.
By choosing her weighings carefully, Sally is able to ensure that she will find the counterfeit coin with exactly three weighings.

Input

The first line of input is an integer n (n > 0) specifying the number of cases to follow. Each case consists of three lines of input, one for each weighing. Sally has identified each of the coins with the letters A--L. Information on a weighing will be given by two strings of letters and then one of the words ``up'', ``down'', or ``even''. The first string of letters will represent the coins on the left balance; the second string, the coins on the right balance. (Sally will always place the same number of coins on the right balance as on the left balance.) The word in the third position will tell whether the right side of the balance goes up, down, or remains even.

Output

For each case, the output will identify the counterfeit coin by its letter and tell whether it is heavy or light. The solution will always be uniquely determined.

Sample Input

1 
ABCD EFGH even 
ABCI EFJK up 
ABIJ EFGH even 

Sample Output

K is the counterfeit coin and it is light. 

Source

大概意思就是有12枚硬币从A到L,其中有一枚是假币,但是不知道轻重。称了三次,每次给定左边硬币和右边硬币以及右边天秤的情况,三次称量一定会确定一枚假币,问哪个硬币是假的并说明假币轻了还是重了。
 
思路:把十二枚硬币的情况都枚举一遍,一枚硬币如果是假币会有是轻假币还是重假币的情况,都需要枚举出来。从A到L依次假设为假币,看是否符合三次称量,因为只有一个假币,所以肯定只有一个硬币是假币时,才会满足给出的三次测量的情形。
#include<iostream>
#include<string.h>
using namespace std;
char cleft[3][7];//一共12个硬币,每次一边最多6个
char cright[3][7];
char result[3][7]; 
int num;
bool isFake(char c,bool heavy);//不加括号体 
int main()
{

	cin >> num;
	while(num-- !=0)
	{
		for(int i = 0;i<3;i++)
		{
			cin >> cleft[i] >>cright[i]>>result[i];
		}
		for(char i = 'A';i<='L';++i)
		{
			if(isFake(i,true))
			{
				cout <<i<<" is the counterfeit coin and it is heavy. "<<endl;
				break;
			}
			else if(isFake(i,false))
			{
				cout <<i<<" is the counterfeit coin and it is light. "<<endl;
				break;
			}
		}
	}
	return 0;
}

bool isFake(char c,bool heavy)
{
	for(int i = 0;i<3;++i)
	{
		switch(result[i][0])
		{
			case 'u':
				if(heavy == true && strchr(cleft[i],c)==NULL )//重 假币肯定在左边
						return false;
				if(heavy == false && strchr(cright[i],c)==NULL )//轻 假币肯定在右边
						return false;
				break;		
			case 'd':
				if(heavy == true && strchr(cright[i],c)==NULL )//假币肯定在右边,并且重 
						return false;
				if(heavy == false && strchr(cleft[i],c)==NULL )//假币肯定在左边,并且轻 
						return false;
				break;		
			case 'e':
				if(strchr(cleft[i],c)!=NULL || strchr(cright[i],c)!=NULL  )//假币不在两边 
						return false;
				break;	
		}
	}
	return true;
}

strchr语法:
  #include <string.h>
  char *strchr( const char *str, int ch );
功能:函数返回一个指向str 中ch 首次出现的位置,当没有在str 中找ch到返回NULL。

转载于:https://www.cnblogs.com/knmxx/p/10308264.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
系统根据B/S,即所谓的电脑浏览器/网络服务器方式,运用Java技术性,挑选MySQL作为后台系统。系统主要包含对客服聊天管理、字典表管理、公告信息管理、金融工具管理、金融工具收藏管理、金融工具银行卡管理、借款管理、理财产品管理、理财产品收藏管理、理财产品银行卡管理、理财银行卡信息管理、银行卡管理、存款管理、银行卡记录管理、取款管理、转账管理、用户管理、员工管理等功能模块。 文中重点介绍了银行管理的专业技术发展背景和发展状况,随后遵照软件传统式研发流程,最先挑选适用思维和语言软件开发平台,依据需求分析报告模块和设计数据库结构,再根据系统功能模块的设计制作系统功能模块图、流程表和E-R图。随后设计架构以及编写代码,并实现系统能模块。最终基本完成系统检测和功能测试。结果显示,该系统能够实现所需要的作用,工作状态没有明显缺陷。 系统登录功能是程序必不可少的功能,在登录页面必填的数据有两项,一项就是账号,另一项数据就是密码,当管理员正确填写并提交这二者数据之后,管理员就可以进入系统后台功能操作区。进入银行卡列表,管理员可以进行查看列表、模糊搜索以及相关维护等操作。用户进入系统可以查看公告和模糊搜索公告信息、也可以进行公告维护操作。理财产品管理页面,管理员可以进行查看列表、模糊搜索以及相关维护等操作。产品类型管理页面,此页面提供给管理员的功能有:新增产品类型,修改产品类型,删除产品类型。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值