Min Number

Problem Description

Now you are given one non-negative integer n in 10-base notation, it will only contain digits ('0'-'9'). You are allowed to choose 2 integers i and j, such that: i!=j, 1≤i<j≤|n|, here |n| means the length of n’s 10-base notation. Then we can swap n[i] and n[j].

For example, n=9012, we choose i=1, j=3, then we swap n[1] and n[3], then we get 1092, which is smaller than the original n.

Now you are allowed to operate at most M times, so what is the smallest number you can get after the operation(s)?

Please note that in this problem, leading zero is not allowed!

Input

The first line of the input contains an integer T (T≤100), indicating the number of test cases.

Then T cases, for any case, only 2 integers n and M (0≤n<10^1000, 0≤M≤100) in a single line.

Output

For each test case, output the minimum number we can get after no more than M operations.

Sample Input

3 9012 0 9012 1 9012 2

Sample Output

9012 1092 1029
题意:给出一个数字串,和最多允许交换的次数。求交换后的最小数字串(首位不能为零)
题解:每次找到一个最小位与当前位交换,贪心即可
#include<stdio.h>
#include<string>
#include<iostream>
using namespace std;
int p[1010];
void swap(int &a,int &b)
{
 int temp=a;
 a=b;
 b=temp;
}
int main()
{
 int test,m,i,j,pos;
 string s;
 scanf("%d",&test);
    while(test--)
 {
        cin>>s>>m;
  int len=s.length();
  for(i=0;i<s.length();i++) p[i]=s[i]-'0';
  int maxi=10;
  int cnt=0;
  if(m)
  {
   for(i=1;i<s.length();i++)
   {
    if(p[i]<maxi&&p[i]!=0) {maxi=p[i];pos=i;}
   }
     if(maxi<p[0]) {swap(p[0],p[pos]);cnt++;}
      for(i=1;i<len-1;i++)
      {
       maxi=10;
      if(cnt==m) break;
      for(j=i+1;j<len;j++)
      {
       if(p[j]<maxi) {maxi=p[j];pos=j;}
      }
      if(maxi<p[i]) {swap(p[i],p[pos]);cnt++;}
      }
  }
  for(i=0;i<len;i++) printf("%d",p[i]);
  printf("\n");
 }
 return 0;
}

转载于:https://www.cnblogs.com/ffhuguang/p/3341230.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值