One-Two-Three

Your little brother has just learnt to write one, two and three, in English. He has written a lot of those words in a paper, your task is to recognize them. Note that your little brother is only a child, so he may make small mistakes: for each word, there might be at most one wrong letter. The word length is always correct. It is guaranteed that each letter he wrote is in lower-case, and each word he wrote has a unique interpretation.

 

Input 

The first line contains the number of words that your little brother has written. Each of the following lines contains a single word with all letters in lower-case. The words satisfy the constraints above: at most one letter might be wrong, but the word length is always correct. There will be at most 10 words in the input.

 

Output 

For each test case, print the numerical value of the word.

 

Sample Input 

 

3
owe
too
theee

 

Sample Output 

 

1
2
3

分析:
相当于字符和数字间的转换,已知长度没有错误,每个字符最多错一个地方

代码:
#include<stdio.h>
#include<string.h>
int main()
{
    int n,l,i;
    char s[10];
    scanf("%d",&n);
        while(n--)
        {
            scanf("%s",s);
            l=strlen(s);
            if(l==5)
               printf("3\n");
            else
            {
                if(s[0]=='o'&&s[1]=='n'||s[0]=='o'&&s[2]=='e'||s[1]=='n'&&s[2]=='e')
                   printf("1\n");
                else
                   printf("2\n");
            }
        }
    
    return 0;
}

 

 

参考代码:

#include<set>
#include<map>
#include<stack>
#include<queue>
#include<ctime>
#include<cmath>
#include<vector>
#include<string>
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<iostream>
#include<algorithm>
#define Master Love
#define YYF Handsome
#define Rp Maxunsignedlonglongint
#define Orz zhanhb8 qs1994
#define Designer Zero
#define zhx zh[x]
#define lth th<<1
#define rth th<<1|1
#define middle (nl+nr)>>1
#define MAX(a,b)  (a>b)?a:b
#define MIN(a,b)  (a<b)?a:b
#define getlen(s)  strlen(s+1)
#define outputans cout<<ans<<endl
#define inputint(k) scanf("%d",&k)
#define inputchar(c) scanf("%c",&c)
#define input64(k) scanf("%I64d",&k)
#define inputdouble(k) scanf("%lf",&k)
#define inputstring(s) scanf("%s",s+1)
#define forout(i,l,r) for(i=l;i<=r;i++)
#define forin(i,l,r) for(int i=l;i<=r;i++)
#define clearit(a,k) memset(a,k,sizeof(a))
#define formatrix for(int i=1;i<=m;i++)for(int j=1;j<=n;j++)
#pragma warning(disable:4996)
using namespace std;
int T;
char s[521];
int main(){
    cin >> T;
    while (T--){
        inputstring(s);
        int len = strlen(s + 1);
        if (len == 5)printf("3\n");
        else {
            int cnt = 0;
            if (s[1] == 't')cnt++;
            if (s[2] == 'w')cnt++;
            if (s[3] == 'o')cnt++;
            if (cnt >= 2)printf("2\n");
            else printf("1\n");
        
        }
    
    }
    return 0;
}

转载于:https://www.cnblogs.com/lipching/p/3854609.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值