rng_10s 【数论】(扩展欧几里得)

题目描述
Ringo Mart, a convenience store, sells apple juice.
On the opening day of Ringo Mart, there were A cans of juice in stock in the morning. Snuke buys B cans of juice here every day in the daytime. Then, the manager checks the number of cans of juice remaining in stock every night. If there are C or less cans, D new cans will be added to the stock by the next morning.
Determine if Snuke can buy juice indefinitely, that is, there is always B or more cans of juice in stock when he attempts to buy them. Nobody besides Snuke buy juice at this store.
Note that each test case in this problem consists of T queries.

Constraints
1≤T≤300
1≤A,B,C,D≤1018
All values in input are integers.

 

输入
Input is given from Standard Input in the following format:
T
A1 B1 C1 D1
A2 B2 C2 D2
:
AT BT CT DT
In the i-th query, A=Ai,B=Bi,C=Ci,D=Di.

 

输出
Print T lines. The i-th line should contain Yes if Snuke can buy apple juice indefinitely in the i-th query; No otherwise.

 

样例输入

复制样例数据

14
9 7 5 9
9 7 6 9
14 10 7 12
14 10 8 12
14 10 9 12
14 10 7 11
14 10 8 11
14 10 9 11
9 10 5 10
10 10 5 10
11 10 5 10
16 10 5 10
1000000000000000000 17 14 999999999999999985
1000000000000000000 17 15 999999999999999985
样例输出
No
Yes
No
Yes
Yes
No
No
Yes
No
Yes
Yes
No
No
Yes

 

提示

In the first query, the number of cans of juice in stock changes as follows: (D represents daytime and N represents night.)

***
In the second query, the number of cans of juice in stock changes as follows:

and so on, thus Snuke can buy juice indefinitely.

 

分析:

参考:https://blog.csdn.net/qq_34454069/article/details/81055250

扩展欧几里得是用来在已知a, b求解一组xy,使它们满足贝祖等式: ax+by = gcd(a, b) =d(解一定存在,根据数论中的相关定理)

ax+by凑出的一定是d的倍数

 

特殊的:a<b||d<b 输出No

一般情况下:1.a>=b&&d>=b

  若c<a-bx+dy<b 有解输出No   (即可以消耗到大于c 但是小于b 那么下一天则不符合)

  即a-b<bx-dy<a-c有解

  又因为bx-dy一定等于gcd(b,d)的倍数

  所以就是求gcd(b,d)的倍数有没有在(a-b,a-c)的

    若有则No

    否则Yes

代码:

 

#include <bits/stdc++.h>

using namespace std;
typedef long long ll;

ll gcd(ll a,ll b){return a%b==0?b:gcd(b,a%b);}

int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        ll a,b,c,d;
        scanf("%lld%lld%lld%lld",&a,&b,&c,&d);
        if(a<b||d<b)
        {
            printf("No\n");
            continue;
        }
        if(c+1>=b)
        {
            printf("Yes\n");
            continue;
        }
        ll tmp = gcd(b,d);
        ll one = 1;
        if((a-c-one)/tmp-(a-b)/tmp>0)
            printf("No\n");
        else
            printf("Yes\n");
    }
}

 

 

 

转载于:https://www.cnblogs.com/hao-tian/p/10376670.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
资源包主要包含以下内容: ASP项目源码:每个资源包中都包含完整的ASP项目源码,这些源码采用了经典的ASP技术开发,结构清晰、注释详细,帮助用户轻松理解整个项目的逻辑和实现方式。通过这些源码,用户可以学习到ASP的基本语法、服务器端脚本编写方法、数据库操作、用户权限管理等关键技术。 数据库设计文件:为了方便用户更好地理解系统的后台逻辑,每个项目中都附带了完整的数据库设计文件。这些文件通常包括数据库结构图、数据表设计文档,以及示例数据SQL脚本。用户可以通过这些文件快速搭建项目所需的数据库环境,并了解各个数据表之间的关系和作用。 详细的开发文档:每个资源包都附有详细的开发文档,文档内容包括项目背景介绍、功能模块说明、系统流程图、用户界面设计以及关键代码解析等。这些文档为用户提供了深入的学习材料,使得即便是从零开始的开发者也能逐步掌握项目开发的全过程。 项目演示与使用指南:为帮助用户更好地理解和使用这些ASP项目,每个资源包中都包含项目的演示文件和使用指南。演示文件通常以视频或图文形式展示项目的主要功能和操作流程,使用指南则详细说明了如何配置开发环境、部署项目以及常见问题的解决方法。 毕业设计参考:对于正在准备毕业设计的学生来说,这些资源包是绝佳的参考材料。每个项目不仅功能完善、结构清晰,还符合常见的毕业设计要求和标准。通过这些项目,学生可以学习到如何从零开始构建一个完整的Web系统,并积累丰富的项目经验。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值