FZU——2111Min Number(多次交换得到最小数,水题)

Problem 2111 Min Number

Accept: 760    Submit: 1516
Time Limit: 1000 mSec    Memory Limit : 32768 KB

Problem Description

Now you are given one non-negative integer n in 10-base notation, it will only contain digits ('0'-'9'). You are allowed to choose 2 integers i and j, such that: i!=j, 1≤i<j≤|n|, here |n| means the length of n’s 10-base notation. Then we can swap n[i] and n[j].

For example, n=9012, we choose i=1, j=3, then we swap n[1] and n[3], then we get 1092, which is smaller than the original n.

Now you are allowed to operate at most M times, so what is the smallest number you can get after the operation(s)?

Please note that in this problem, leading zero is not allowed!

Input

The first line of the input contains an integer T (T≤100), indicating the number of test cases.

Then T cases, for any case, only 2 integers n and M (0≤n<10^1000, 0≤M≤100) in a single line.

Output

For each test case, output the minimum number we can get after no more than M operations.

Sample Input

3
9012 0
9012 1
9012 2

Sample Output

9012
1092
1029

Source

“高教社杯”第三届福建省大学生程序设计竞赛

 

无聊找找以前写过的题目,果然还是Too naïve,第一次提交RE了,回去看看是自定义函数可能会返回让数组越界的值....改完AC了

代码:

#include<iostream>
#include<algorithm>
#include<cstdlib>
#include<sstream>
#include<cstring>
#include<cstdio>
#include<string>
#include<deque>
#include<cmath>
#include<queue>
#include<set>
#include<map>
using namespace std;
int findmin(const string &s,const int &b)//查找起始点之后的最小数
{
	int len=s.size(),index=b,t=s[b];
	int i;
	if(b==0)//前导零的情况
	{
		for (int i=b; i<len; i++)
		{
			if(s[i]<t&&s[i]>'0')
			{
				index=i;
				t=s[i];
			}
		} 
	}
	else
	{
		for (int i=b; i<len; i++)
		{
			if(s[i]<t)
			{
				index=i;
				t=s[i];
			}
		} 
	}
	return index;
}
int main (void)
{
	int t,i,j,cnt,n,p,be,LEN;
	string s;
	cin>>t;
	while (t--)
	{
		cin>>s>>n;
		cnt=be=0;
		LEN=s.size();
		while (cnt<n)
		{
			if(be>=LEN)
				break;
			p=findmin(s,be);
			if(s[be]==s[p])//若找到的位置本来就是自己,意味着不需要交换.
			{
				be++;//起始点+1
				continue;
			}
			swap(s[be],s[p]);
			cnt++;
		}	
		cout<<s<<endl;
	}
	return 0;
}

转载于:https://www.cnblogs.com/Blackops/p/5356392.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值