zju 简单计算题

A - Clock
Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%lld & %llu

Description

It is known that, in one day the hour hand and the minute hand of a clock meet 22 times. But in one day, how long is the time that the angle between the hour hand and the minute hand is no more than x degrees?

Note that in this problem, both hands move smoothly (they don't "jump").

Input

The first line of the input is an integer indicating the number of test cases (no more than 200).

For each case, there is only one integer x (0 <= x <= 180) giving the angle.

Output

For each case, output for how many seconds in one day that the angle between the hour hand and the minute hand is no more than x degrees. You need to print two digits after the decimal point (as the format in sample).

Sample Input

3
0
180
7

Sample Output

0.00
86400.00
3360.00
用到了题目给出的信息,分针和时针在24h相遇22次,为什么我自己推得公式怎么就不对了呢
View Code
#include <iostream>
#include <cstdio>

using namespace std;

int main(){
double degree;
int ca;
cin>>ca;
while(ca--){
cin>>degree;
degree*=10*12*4;
printf("%.2lf\n",degree);
}
return 0;
}


 

转载于:https://www.cnblogs.com/one--world--one--dream/archive/2012/04/06/2435125.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值