强制设置IE浏览器的版本模式

转载自:http://blog.csdn.net/huwenhu2007/article/details/17954119

 

1.<meta http-equiv="X-UA-Compatible" content="IE=7" /> 通过在页面head标签中添加该属性来进行设置;

2.对于页面中引入了公共JSP页面的需要在公共JSP页面中也进行设置:

<%@ page language="java" pageEncoding="UTF-8"%>
<%@ taglib uri="http://java.sun.com/jsp/jstl/core" prefix="c"%>
<%@ taglib uri="http://java.sun.com/jsp/jstl/fmt" prefix="fmt"%>
<%@ taglib uri="http://java.sun.com/jsp/jstl/functions" prefix="fn"%>
<html>
<head>
     <!-- 加上html标签和meta -->
     <meta http-equiv="X-UA-Compatible" content="IE=7" /> 
</head> 
<c:set var="ctxPath" value="${pageContext.request.contextPath}" />
<!-- 正式环境IP:10.109.81.6  测试环境IP:10.103.117.11 -->
<c:set var="cognosPath" value="http://10.103.117.11/cognos10/cgi-bin/cognos.cgi" />
</html>


<script type="text/javascript">
var path = "${ctxPath}";
var cognosPath = "${cognosPath}";
</script>

3.对于iframe或者frame加载的页面也需要进行单独设置:

<head>
     <!-- 加上html标签和meta -->
     <meta http-equiv="X-UA-Compatible" content="IE=7" /> 
</head> 

转载于:https://www.cnblogs.com/lxboy2009/p/5388017.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值