1054. The Dominant Color (20)

题目如下:

Behind the scenes in the computer's memory, color is always talked about as a series of 24 bits of information for each pixel. In an image, the color with the largest proportional area is called the dominant color. A strictly dominant color takes more than half of the total area. Now given an image of resolution M by N (for example, 800x600), you are supposed to point out the strictly dominant color.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive numbers: M (<=800) and N (<=600) which are the resolutions of the image. Then N lines follow, each contains M digital colors in the range [0, 224). It is guaranteed that the strictly dominant color exists for each input image. All the numbers in a line are separated by a space.

Output Specification:

For each test case, simply print the dominant color in a line.

Sample Input:
5 3
0 0 255 16777215 24
24 24 0 0 24
24 0 24 24 24
Sample Output:
24


题目要求从一个线性表中找出出现次数最多的元素,可以使用map统计每个元素的出现次数,然后动态的统计当前出现次数最多的。

#include <iostream>
#include <map>
#include <stdio.h>

using namespace std;

int main()
{
    int maxCnt = -1;
    int maxColor = -1;
    map<int,int> colorMap;
    int M,N;
    cin >> M >> N;
    int color;
    for(int i = 0; i < N; i++){
        for(int j = 0; j < M; j++){
            scanf("%d",&color);
            if(colorMap.find(color) == colorMap.end()){
                colorMap[color] = 1;
            }else{
                colorMap[color]++;
            }
            if(maxCnt < colorMap[color]){
                maxCnt = colorMap[color];
                maxColor = color;
            }
        }
    }
    cout << maxColor << endl;
    return 0;
}


转载于:https://www.cnblogs.com/aiwz/p/6154119.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值