UASCO Count the rectangles

Count the rectangles

TimeLimit: 2 Second   MemoryLimit: 64 Megabyte

Totalsubmit: 64   Accepted: 36  

Description

You are given numbers of rectangles made of '1's and '0's.Calculate how many small rectangles which have four '1's on the four corners.

Input

There are several test cases, each test case starts with a line containing two positive integers n and m. n and m is the size of the rectangle (1<=n<=100, 1<=m<=100). Next follow a rectangle which contains only number '0' and '1'. The input will finish with the end of file.

Output

The number of rectangles which meet the requirements.

Sample Input

3 4
1 0 1 0
0 1 1 0
1 1 1 0

Sample Output

2

Source

zzx

 

思路:

 
代码:
#include <iostream>
#include <cstdio>
#include <cstring>
#include <cstdlib>
#include <algorithm>
using namespace std;
int map[110][110];
int the_last_sum;
int the_long_x;
int the_long_y;
int n,m;
int main()
{
    while(scanf("%d%d",&n,&m) != EOF)
    {
        memset(map,0,sizeof(map));
        for(int i = 1;i <= n;i ++)
            for(int j = 1;j <= m;j ++)
                scanf("%d",&map[i][j]);
        the_last_sum = 0;
        for(int i = 1;i <= n;i ++)
            for(int j = 1;j <= m;j ++)
            {
                 the_long_x = 0;
                 the_long_y = 0;
                 if(map[i][j] == 1 && j + 1 <= m && i + 1 <= n)
                 {
                     for(int k = j + 1;k <= m;k ++)
                     {
                         if(map[i][k] == 1)
                         {

                             the_long_y = k - j;
                             for(int l = i + 1;l <= n;l ++)
                             {
                                if(map[l][j] == 1)
                                {
                                      the_long_x = l - i;
                                      if(the_long_x != 0 && the_long_y != 0)
                                      {
                                           if(i + the_long_x <= n && j + the_long_y <= m
                                           && map[i + the_long_x][j + the_long_y] == 1)
                                                       the_last_sum ++;
                                      }
                                }
                             }
                         }
                     }
                 }
            }
      printf("%d\n",the_last_sum);
    }
    return 0;
}

 

转载于:https://www.cnblogs.com/GODLIKEING/p/3426710.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值