HDU 1018 Big Number (斯特灵公式)

In many applications very large integers numbers are required. Some of these applications are using keys for secure transmission of data, encryption, etc. In this problem you are given a number, you have to determine the number of digits in the factorial of the number. 

InputInput consists of several lines of integer numbers. The first line contains an integer n, which is the number of cases to be tested, followed by n lines, one integer 1 ≤ n ≤ 10 7 on each line. 
OutputThe output contains the number of digits in the factorial of the integers appearing in the input. 
Sample Input

2
10
20

Sample Output

7
19 

这里N的范围较小可以直接用对数做,这里还是写一下斯特灵公式的写法
斯特林公式判断n>=1的情况,如果存在n==0则需另外特判

 

 
 

  斯特灵公式是一条用来取n阶乘近似值的数学公式。 公式为: 斯特林公式可以用来估算某数的大小,结合lg可以估算某数的位数,或者可以估算某数的阶乘是另一个数的倍数。 

 

代码如下:

#include <cstdio>
#include <algorithm>
#include <iostream>
#include <vector>
#include <cstring>
#include <cmath>
using namespace std;
typedef long long LL;
const double e = 2.718281828459;
const double Pi=acos(-1.0);
int main()
{
    LL t,n,ans;
    cin>>t;
    while(t--)
    {
       cin>>n;
       ans=log10((2*Pi*n))/2+n*log10(n/e)+1;
       cout<<ans<<endl;
    }
    return 0;
}

 

转载于:https://www.cnblogs.com/a249189046/p/8409296.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值