HDOJ--2680--Choose the best route

Choose the best route

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 10372    Accepted Submission(s): 3342


Problem Description
One day , Kiki wants to visit one of her friends. As she is liable to carsickness , she wants to arrive at her friend’s home as soon as possible . Now give you a map of the city’s traffic route, and the stations which are near Kiki’s home so that she can take. You may suppose Kiki can change the bus at any station. Please find out the least time Kiki needs to spend. To make it easy, if the city have n bus stations ,the stations will been expressed as an integer 1,2,3…n.
 

Input
There are several test cases.
Each case begins with three integers n, m and s,(n<1000,m<20000,1=<s<=n) n stands for the number of bus stations in this city and m stands for the number of directed ways between bus stations .(Maybe there are several ways between two bus stations .) s stands for the bus station that near Kiki’s friend’s home.
Then follow m lines ,each line contains three integers p , q , t (0<t<=1000). means from station p to station q there is a way and it will costs t minutes .
Then a line with an integer w(0<w<n), means the number of stations Kiki can take at the beginning. Then follows w integers stands for these stations.
 

Output
The output contains one line for each data set : the least time Kiki needs to spend ,if it’s impossible to find such a route ,just output “-1”.
 

Sample Input
 
   
5 8 5 1 2 2 1 5 3 1 3 4 2 4 7 2 5 6 2 3 5 3 5 1 4 5 1 2 2 3 4 3 4 1 2 3 1 3 4 2 3 2 1 1
 

Sample Output
 
   
1 -1
题意:琪琪想要去拜訪她的朋友,可是这货easy晕车,所以要找一个花费时间最少的路线。

如今给你路线图。让你找出从她家附近的起点站(能够有多个)到朋友家附近的终点站(仅仅有一个)花费时间最少的路线。各个网站的编号从1到n。

 
思路:最開始我是直接无脑用DIJ算法做的结果丝毫不意外(TLE)了,FUCK。看了看别人的思路才造应该把终点当起点反向构图,注意,这是个单向图。
AC代码:
#include<stdio.h>
#include<string.h>
#define INF 0x3f3f3f3f
#include<algorithm>
using namespace std;
int vis[1010],map[1010][1010],dis[1010],n,ans[1010],num,beg;
void init(){
	for(int i=1;i<=n;i++)
		for(int j=0;j<=n;j++){
			if(i==j)
				map[i][j]=map[j][i]=0;
			else
				map[i][j]=map[j][i]=INF;
		}
}
void dijkstra(){
	int k=0,flag=0,i;
		memset(vis,0,sizeof(vis));
		for(i=1;i<=n;i++)
			dis[i]=map[beg][i];
		vis[beg]=1;
		for(i=1;i<=n;i++){
			int j,key,temp=INF;
			for(int j=1;j<=n;j++)
				if(!vis[j]&&temp>dis[j])
					temp=dis[key=j];
			if(temp==INF){
				break;
			}
			vis[key]=1;
			for(int j=1;j<=n;j++)
				if(!vis[j]&&dis[j]>dis[key]+map[key][j])
					dis[j]=dis[key]+map[key][j];
		}
}
int main(){
	int m;
	while(scanf("%d%d%d",&n,&m,&beg)!=EOF){
		int i;
		memset(ans,INF,sizeof(INF));
		init();//注意要初始化。 
		for(i=1;i<=m;i++){
			int a,b,cost;
			scanf("%d%d%d",&a,&b,&cost);
			if(map[b][a]>cost)//过滤掉同样的边。反向构图。

map[b][a]=cost; } scanf("%d",&num); dijkstra();//直接找到各个终点的位置。 for(i=0;i<num;i++){ int end; scanf("%d",&end); ans[i]=dis[end]; } sort(ans,ans+num); if(ans[0]==INF)//推断是否存在这种值。不存在的话ans数组肯定每个都是INF。 printf("-1\n"); else printf("%d\n",ans[0]); } return 0; }

再次使用SPFA过一次。这道题非常坑,哦,不,非常坑。假设你数组开小了。用G++提交会显示超时而不是RE,不明觉厉。
ac代码:
#include<stdio.h>
#include<string.h>
#include<queue>
#define INF 0x3f3f3f3f
#define N 1010
#define M 20100
using namespace std;
int dis[N],vis[N],n,m,edgenum,head[N];
struct node{
	int from,to,cost,next;
}edge[M];//结构体是用来记录边的数量的。应该开到M; 
void init(){
	edgenum=0;
	memset(head,-1,sizeof(head));//表头应注意初始时为-1。 
}
void add(int u,int v,int cost){
	node E={u,v,cost,head[u]};
	edge[edgenum]=E;
	head[u]=edgenum++;
}
void spfa(int beg){
	queue<int>q;
	memset(dis,INF,sizeof(dis));
	memset(vis,0,sizeof(vis));
	dis[beg]=0;
	vis[beg]=1;
	q.push(beg);
	while(!q.empty()){
		int i,u=q.front();
		q.pop();
		vis[u]=0;
		for(i=head[u];i!=-1;i=edge[i].next){
			int v=edge[i].to;
			if(dis[v]>dis[u]+edge[i].cost){
				dis[v]=dis[u]+edge[i].cost;
				if(!vis[v]){
					vis[v]=1;
					q.push(v);
				}
			}
		}
	}
}
int main(){
	int beg;
	while(scanf("%d%d%d",&n,&m,&beg)!=EOF){
		init();
		while(m--){
			int a,b,c;
			scanf("%d%d%d",&a,&b,&c);
			add(b,a,c);
		}
		spfa(beg);
		int e,min=INF;
		scanf("%d",&e);
		while(e--){
			int end;
			scanf("%d",&end);
			if(min>dis[end])
				min=dis[end];
		}
		if(min==INF)
			printf("-1\n");
		else
			printf("%d\n",min);
	}
	return 0;
}



转载于:https://www.cnblogs.com/jzssuanfa/p/7288901.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
探索全栈前端技术的魅力:HTML+CSS+JS+JQ+Bootstrap网站源码深度解析 在这个数字化时代,构建一个既美观又功能强大的网站成为了许多开发者和企业追逐的目标。本份资源精心汇集了一套完整网站源码,融合了HTML的骨架搭建、CSS的视觉美化、JavaScript的交互逻辑、jQuery的高效操作以及Bootstrap的响应式设计,全方位揭秘了现代网页开发的精髓。 HTML,作为网页的基础,它构建了信息的框架;CSS则赋予网页生动的外观,让设计创意跃然屏上;JavaScript的加入,使网站拥有了灵动的交互体验;jQuery,作为JavaScript的强力辅助,简化了DOM操作与事件处理,让编码更为高效;而Bootstrap的融入,则确保了网站在不同设备上的完美呈现,响应式设计让访问无界限。 通过这份源码,你将: 学习如何高效组织HTML结构,提升页面加载速度与SEO友好度; 掌握CSS高级技巧,如Flexbox与Grid布局,打造适应各种屏幕的视觉盛宴; 理解JavaScript核心概念,动手实现动画、表单验证等动态效果; 利用jQuery插件快速增强用户体验,实现滑动效果、Ajax请求等; 深入Bootstrap框架,掌握移动优先的开发策略,响应式设计信手拈来。 无论是前端开发新手渴望系统学习,还是资深开发者寻求灵感与实用技巧,这份资源都是不可多得的宝藏。立即深入了解,开启你的全栈前端探索之旅,让每一个网页都成为技术与艺术的完美融合!

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值