I love sneakers!(分组背包HDU3033)

I love sneakers!

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4602    Accepted Submission(s): 1893


Problem Description
After months of hard working, Iserlohn finally wins awesome amount of scholarship. As a great zealot of sneakers, he decides to spend all his money on them in a sneaker store.

There are several brands of sneakers that Iserlohn wants to collect, such as Air Jordan and Nike Pro. And each brand has released various products. For the reason that Iserlohn is definitely a sneaker-mania, he desires to buy at least one product for each brand.
Although the fixed price of each product has been labeled, Iserlohn sets values for each of them based on his own tendency. With handsome but limited money, he wants to maximize the total value of the shoes he is going to buy. Obviously, as a collector, he won’t buy the same product twice.
Now, Iserlohn needs you to help him find the best solution of his problem, which means to maximize the total value of the products he can buy.
 

Input
Input contains multiple test cases. Each test case begins with three integers 1<=N<=100 representing the total number of products, 1 <= M<= 10000 the money Iserlohn gets, and 1<=K<=10 representing the sneaker brands. The following N lines each represents a product with three positive integers 1<=a<=k, b and c, 0<=b,c<100000, meaning the brand’s number it belongs, the labeled price, and the value of this product. Process to End Of File.
 

Output
For each test case, print an integer which is the maximum total value of the sneakers that Iserlohn purchases. Print "Impossible" if Iserlohn's demands can’t be satisfied.
 

Sample Input
 
  
5 10000 3 1 4 6 2 5 7 3 4 99 1 55 77 2 44 66
 

Sample Output
 
  
255
 

Source
2009 Multi-University Training Contest 13 - Host by HIT

分组背包+01背包,要求每组物品最少取一个
#include <set>
#include <map>
#include <list>
#include <stack>
#include <cmath>
#include <vector>
#include <queue>
#include <string>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <iostream>
#include <algorithm>
using namespace std;

typedef long long LL;

const int INF = 0x3f3f3f3f;

typedef struct node
{
    int Fee;
    int val;
} SN;

SN a;
int n,m,K;
int Dp[12][11000];
vector<SN>s[12];
int main()
{
    int flag,fe,va;
    while(~scanf("%d %d %d",&n,&m,&K))
    {
        memset(Dp,-1,sizeof(Dp));
        memset(Dp[0],0,sizeof(Dp[0]));
        for(int i=0; i<=K; i++)
        {
            s[i].clear();
        }
        for(int i=1; i<=n; i++)
        {
            scanf("%d %d %d",&flag,&fe,&va);
            a.Fee=fe;
            a.val=va;
            s[flag].push_back(a);
        }
        for(int i=1; i<=K; i++)
        {
            for(int j=0;j<s[i].size();j++)
            {
                for(int k=m;k>=s[i][j].Fee;k--)
                {
                    if(Dp[i][k-s[i][j].Fee]!=-1)//顺序不可颠掉
                    {
                        Dp[i][k]=max(Dp[i][k],Dp[i][k-s[i][j].Fee]+s[i][j].val);
                    }
                    if(Dp[i-1][k-s[i][j].Fee]!=-1)
                    {
                        Dp[i][k]=max(Dp[i][k],Dp[i-1][k-s[i][j].Fee]+s[i][j].val);
                    }

                }
            }
        }
        if(Dp[K][m]==-1)
        {
            printf("Impossible\n");
        }
        else
        {
            printf("%d\n",Dp[K][m]);
        }
    }
    return 0;
    /*
 4 5 2
 1 2 3
 1 3 2
 2 2 3
 2 3 2

 3 5 3
 1 2 5
 2 2 1
 3 2 2

 3 5 3
 1 0 5
 2 0 1
 3 0 2
 */
}





 

转载于:https://www.cnblogs.com/juechen/p/5255939.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值