uestc 1221 Ancient Go

Time Limit: 3000/1000MS (Java/Others)     Memory Limit: 65535/65535KB (Java/Others)
Submit  Status

Yu Zhou likes to play Go with Su Lu. From the historical research, we found that there are much difference on the rules between ancient go and modern go.

Here is the rules for ancient go they were playing:

  • The game is played on a 8×8 cell board, the chess can be put on the intersection of the board lines, so there are 9×9 different positions to put the chess.
  • Yu Zhou always takes the black and Su Lu the white. They put the chess onto the game board alternately.
  • The chess of the same color makes connected components(connected by the board lines), for each of the components, if it's not connected with any of the empty cells, this component dies and will be removed from the game board.
  • When one of the player makes his move, check the opponent's components first. After removing the dead opponent's components, check with the player's components and remove the dead components.

One day, Yu Zhou was playing ancient go with Su Lu at home. It's Yu Zhou's move now. But they had to go for an emergency military action. Little Qiao looked at the game board and would like to know whether Yu Zhou has a move to kill at least one of Su Lu's chess.

Input

The first line of the input gives the number of test cases, T(1T100). T test cases follow. Test cases are separated by an empty line. Each test case consist of 9 lines represent the game board. Each line consists of 9 characters. Each character represents a cell on the game board. . represents an empty cell. x represents a cell with black chess which owned by Yu Zhou. o represents a cell with white chess which owned by Su Lu.

Output

For each test case, output one line containing Case #x: y, where x is the test case number (starting from 1) and y is Can kill in one move!!! if Yu Zhou has a move to kill at least one of Su Lu's components. Can not kill in one move!!! otherwise.

Sample input and output

Sample Input Sample Output
2

.......xo
.........
.........
..x......
.xox....x
.o.o...xo
..o......
.....xxxo
....xooo.

......ox.
.......o.
...o.....
..o.o....
...o.....
.........
.......o.
...x.....
........o
Case #1: Can kill in one move!!!
Case #2: Can not kill in one move!!!

Hint

In the first test case, Yu Zhou has 4 different ways to kill Su Lu's component.

In the second test case, there is no way to kill Su Lu's component.

Source

The 2015 China Collegiate Programming Contest
这题可以用宽搜,枚举所有能放'x'旗子的位置,然后看看有没有'o'被围住。

#include<iostream>
#include<stdio.h>
#include<stdlib.h>
#include<string.h>
#include<math.h>
#include<vector>
#include<map>
#include<set>
#include<queue>
#include<stack>
#include<string>
#include<algorithm>
using namespace std;
typedef long long ll;
#define inf 0x7fffffff
#define maxn 12
char s[maxn][maxn];
int vis[maxn][maxn];
int tab[4][2]={0,1,-1,0,0,-1,1,0};

int bfs(int x1,int y1)
{
    int i,j,xx,yy,front,rear,flag=1,x,y;
    int q[1111][2];
    front=rear=1;
    q[front][0]=x1;q[front][1]=y1;

    while(front<=rear){
        x=q[front][0];
        y=q[front][1];
        front++;
        for(i=0;i<4;i++){
            xx=x+tab[i][0];
            yy=y+tab[i][1];
            if(xx>=1 && xx<=9 && yy>=1 && yy<=9 && !vis[xx][yy] && s[xx][yy]!='x'){
                if(s[xx][yy]=='.'){
                    flag=0;
                }
                else{
                    vis[xx][yy]=1;
                    rear++;
                    q[rear][0]=xx;q[rear][1]=yy;
                }

            }

        }
    }
    return flag;


}



int check()
{
    int i,j,flag;
    memset(vis,0,sizeof(vis));
    flag=0;
    for(i=1;i<=9;i++){
        for(j=1;j<=9;j++){
            if(s[i][j]=='o' && !vis[i][j]){
                vis[i][j]=1;
                flag=bfs(i,j);
                if(flag)break;
            }
        }
        if(flag)break;
    }
    return flag;
}


int main()
{
    int i,j,T,k,h,flag,cas=0;
    scanf("%d",&T);
    while(T--)
    {
        for(i=1;i<=9;i++){
            scanf("%s",s[i]+1);
        }
        flag=0;
        for(i=1;i<=9;i++){
            for(j=1;j<=9;j++){
                if(s[i][j]=='.'){
                    s[i][j]='x';
                    flag=check();
                    if(flag){
                        break;
                    }
                    else{
                        s[i][j]='.';
                    }
                }
            }
            if(flag)break;
        }
        cas++;
        if(flag){
            printf("Case #%d: Can kill in one move!!!\n",cas);
        }
        else{
            printf("Case #%d: Can not kill in one move!!!\n",cas);
        }
    }
    return 0;
}


转载于:https://www.cnblogs.com/herumw/p/9464625.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值