hdu 2583 permutation

permutation

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 141    Accepted Submission(s): 81

Problem Description

Permutation plays a very important role in Combinatorics. For example ,1 2 3 4 5 and 1 3 5 4 2 are both 5-permutations. As everyone's known, the number of n-permutations is n!. According to their magnitude relatives ,if we insert the sumbols "<" or ">"between every pairs of consecutive numbers of a permutations,we can get the permutations with symbols. For example,1 2 3 4 5 can be changed to 1<2<3<4<5, 1 3 5 4 2 can be changed to 1<3<5>4>2. Now it's yout task to calculate the number of n-permutations with k"<"symbol. Maybe you don't like large numbers ,so you should just geve the result mod 2009.

Input

Input may contai multiple test cases.
Each test case is a line contains two integers n and k .0<n<=100 and 0<=k<=100.
The input will terminated by EOF.

Output

The nonegative integer result mod 2009 on a line.

Sample Input

5 2

Sample Output

66

 

#include <iostream>

using namespace std;
const int m=2009;
int dp[110][110];

int main()
{
    int n,k,i,j;

    //预处理
    for(i=0;i<=100;i++)
    {
        dp[i][0]=1;
        dp[i][i]=0;
    }
    for(i=1;i<=100;i++)
        for(j=1;j<i;j++)
            if(j==i-1)//k==n-1时,结果为1
                dp[i][j]=1;
            else//状态转移方程dp[i][j]=(j+1)*dp[i-1][j]+(i-j)*dp[i-1][j-1];
                dp[i][j]=((j+1)*dp[i-1][j]%m+(i-j)*dp[i-1][j-1]%m)%m;

    while(cin>>n>>k)
        if(k>n)//n>=k时,结果必为0
            cout<<'0'<<endl;
        else
            cout<<dp[n][k]<<endl;

    return 0;
}



转载于:https://www.cnblogs.com/zyx1314/p/3550152.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值