HDU 5441 Travel

Travel

Time Limit: 1500/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 94    Accepted Submission(s): 32


Problem Description
Jack likes to travel around the world, but he doesn’t like to wait. Now, he is traveling in the Undirected Kingdom. There are  n cities and m bidirectional roads connecting the cities. Jack hates waiting too long on the bus, but he can rest at every city. Jack can only stand staying on the bus for a limited time and will go berserk after that. Assuming you know the time it takes to go from one city to another and that the time Jack can stand staying on a bus is x minutes, how many pairs of city (a,b) are there that Jack can travel from city a to b without going berserk?
 

 

Input
The first line contains one integer  T,T5, which represents the number of test case.

For each test case, the first line consists of three integers n,m and q where n20000,m100000,q5000. The Undirected Kingdom has n cities and mbidirectional roads, and there are q queries.

Each of the following m lines consists of three integers a,b and d where a,b{1,...,n} and d100000. It takes Jack d minutes to travel from city a to city band vice versa.

Then q lines follow. Each of them is a query consisting of an integer x where x is the time limit before Jack goes berserk.

 

 

Output
You should print  q lines for each test case. Each of them contains one integer as the number of pair of cities (a,b) which Jack may travel from a to b within the time limit x.

Note that (a,b) and (b,a) are counted as different pairs and a and b must be different cities.
 

 

Sample Input
1
5 5 3
2 3 6334
1 5 15724
3 5 5705
4 3 12382
1 3 21726
6000
10000
13000
 
Sample Output
2
6
12
 

 

Source
 
并查集离线
/* ***********************************************
Author        :guanjun
Created Time  :2015/9/13 15:57:19
File Name     :4.cpp
************************************************ */
#include <iostream>
#include <cstring>
#include <cstdlib>
#include <stdio.h>
#include <algorithm>
#include <vector>
#include <queue>
#include <set>
#include <map>
#include <string>
#include <math.h>
#include <stdlib.h>
#include <iomanip>
#include <list>
#include <deque>
#include <stack>
#define ull unsigned long long
#define ll long long
#define mod 90001
#define INF 0x3f3f3f3f
#define maxn 100000+10
#define cle(a) memset(a,0,sizeof(a))
const ull inf = 1LL << 61;
const double eps=1e-5;
using namespace std;
struct node{
    int x,y,z;
}edge[maxn];
bool cmp(node a,node b){
    return a.z<b.z;
}
struct pk{
    int w,id;
}q[maxn];
bool cmp1(pk a,pk b){
    return a.w<b.w;
}
int ans[maxn];
int fa[maxn],num[maxn];
int findfa(int x){
    if(x==fa[x])return fa[x];
    else return fa[x]=findfa(fa[x]);
}
int main()
{
    #ifndef ONLINE_JUDGE
    freopen("in.txt","r",stdin);
    #endif
    //freopen("out.txt","w",stdout);
    int n,m,Q,t;
    cin>>t;
    while(t--){
        cin>>n>>m>>Q;
        for(int i=0;i<m;i++)scanf("%d%d%d",&edge[i].x,&edge[i].y,&edge[i].z);
        for(int i=0;i<Q;i++)scanf("%d",&q[i].w),q[i].id=i;
        sort(edge,edge+m,cmp);
        sort(q,q+Q,cmp1);
        for(int i=1;i<=n;i++)fa[i]=i,num[i]=1;
        int cnt=0,j=0;
        for(int i=0;i<Q;i++){
            while(j<m&&edge[j].z<=q[i].w){
                int x=findfa(edge[j].x);
                int y=findfa(edge[j].y);
                if(x!=y){
                    //当 联通块加入一个符合要求的点的时候相应的应该
                    //增加的方案数
                    cnt+=num[x]*num[y];
                    fa[x]=y;
                    num[y]+=num[x];
                }
                j++;
            }
            ans[q[i].id]=2*cnt;
        }
        for(int i=0;i<Q;i++){
            printf("%d\n",ans[i]);
        }
    }
    return 0;
}

 

转载于:https://www.cnblogs.com/pk28/p/4805157.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值