二叉树的表达

2019-08-03

19:52:58

A rooted binary tree is a tree with a root node in which every node has at most two children.

Your task is to write a program which reads a rooted binary tree T and prints the following information for each node u of T:

  • node ID of u
  • parent of u
  • sibling of u
  • the number of children of u
  • depth of u
  • height of u
  • node type (root, internal node or leaf)

If two nodes have the same parent, they are siblings. Here, if u and v have the same parent, we say u is a sibling of v (vice versa).

The height of a node in a tree is the number of edges on the longest simple downward path from the node to a leaf.

Here, the given binary tree consists of n nodes and evey node has a unique ID from 0 to n-1.

Input

The first line of the input includes an integer n, the number of nodes of the tree.

In the next n lines, the information of each node is given in the following format:

id left right

id is the node ID, left is ID of the left child and right is ID of the right child. If the node does not have the left (right) child, the left(right) is indicated by -1.

Output

Print the information of each node in the following format:

node id: parent = p , sibling = s , degree = deg, depth = dep, height = htype

p is ID of its parent. If the node does not have a parent, print -1.

s is ID of its sibling. If the node does not have a sibling, print -1.

degdep and h are the number of children, depth and height of the node respectively.

type is a type of nodes represented by a string (root, internal node or leaf. If the root can be considered as a leaf or an internal node, print root.

Please follow the format presented in a sample output below.

Constraints

  • 1 ≤ n ≤ 25

Sample Input 1

9
0 1 4
1 2 3
2 -1 -1
3 -1 -1
4 5 8
5 6 7
6 -1 -1
7 -1 -1
8 -1 -1

Sample Output 1

node 0: parent = -1, sibling = -1, degree = 2, depth = 0, height = 3, root
node 1: parent = 0, sibling = 4, degree = 2, depth = 1, height = 1, internal node
node 2: parent = 1, sibling = 3, degree = 0, depth = 2, height = 0, leaf
node 3: parent = 1, sibling = 2, degree = 0, depth = 2, height = 0, leaf
node 4: parent = 0, sibling = 1, degree = 2, depth = 1, height = 2, internal node
node 5: parent = 4, sibling = 8, degree = 2, depth = 2, height = 1, internal node
node 6: parent = 5, sibling = 7, degree = 0, depth = 3, height = 0, leaf
node 7: parent = 5, sibling = 6, degree = 0, depth = 3, height = 0, leaf
node 8: parent = 4, sibling = 5, degree = 0, depth = 2, height = 0, leaf
#include <bits/stdc++.h>
using namespace std;
#define MAX 100005
#define NIL -1

int H[MAX];
int D[100005];
struct Node{
    int parent,left,right;
}t[MAX];

void setDepth(int u, int d)
{
    if(u == NIL) return ;
    D[u] = d;
    setDepth(t[u].left, d + 1);
    setDepth(t[u].right, d + 1);
}

int setHeight(int u)
{
    int h1 = 0,h2 = 0;
    if(t[u].left != NIL)
    {
        h1 = setHeight(t[u].left) + 1;
    }
    if(t[u].right != NIL)
    {
        h2 = setHeight(t[u].right) + 1;
    }
    H[u] = max(h1 , h2);
    return H[u];
}

int getSibling(int u)
{
    if(t[u].parent == NIL) return NIL;
    if(t[t[u].parent].left != u && t[t[u].parent].left != NIL)
    {
        return t[t[u].parent].left;
    }
    if(t[t[u].parent].right != u && t[t[u].parent].right != NIL)
    {
        return t[t[u].parent].right;
    }
    return NIL;
}
void print(int u)
{
    printf("node %d: ", u);
    printf("parent = %d, ",  t[u].parent);
    printf("sibling = %d, ", getSibling(u));
    int deg = 0;
    if(t[u].left != NIL) deg++;
    if(t[u].left != NIL) deg++;
    printf("degree = %d, ", deg);
    printf("depth = %d, ", D[u]);
    printf("height = %d, ", H[u]);
    
    if(t[u].parent == NIL)
    {
        printf("root\n");
    }
    else if(t[u].left == NIL && t[u].right == NIL)
    {
        printf("leaf\n");
    } 
    else
    {
         printf("internal node\n");
    }
}
int main()
{
    int n;
    cin >> n;
    int root = 0;
    
    for(int i = 0; i < n; i++) t[i].parent = NIL;
    
    for(int i = 0 ; i < n ;i++)
    {
        int v;
        int l, r;
        cin >> v >> l >> r;
        t[i].left = l;
        t[i].right = r;
        if(l != NIL) t[l].parent = v;
        if(r != NIL) t[r].parent = v;
    }
    
    for(int i = 0; i < n; i++)
    {
        if(t[i].parent == NIL) root = i;
    }
    setDepth(root, 0);
    setHeight(root);
    
    for(int i = 0; i < n; i++)
    {
        print(i);
    }
    cout << getSibling(3) << endl;
    return 0;
}

 

转载于:https://www.cnblogs.com/Artimis-fightting/p/11296051.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值