Inviting Friends(二分+背包)

Inviting Friends
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 241 Accepted Submission(s): 97

Problem Description
You want to hold a birthday party, inviting as many friends as possible, but you have to prepare enough food for them. For each person, you need n kinds of ingredient to make good food. You can use the ingredients in your kitchen, or buy some new ingredient packages. There are exactly two kinds of packages for each kind of ingredient: small and large.

We use 6 integers to describe each ingredient: x, y, s1, p1, s2, p2, where x is the amount (of this ingredient) needed for one person, y is the amount currently available in the kitchen, s1 and p1 are the size (the amount of this ingredient in each package) and price of small packages, s2 and p2 are the size and price of large packages.

Given the amount of money you can spend, your task is to find the largest number of person who can serve. Note that you cannot buy only part of a package.

Input
There are at most 10 test cases. Each case begins with two integers n and m (1<=n<=100, 1<=m<=100000), the number of kinds of ingredient, and the amount of money you have. Each of the following n lines contains 6 positive integers x, y, s1, p1, s2, p2 to describe one kind of ingredient (10<=x<=100, 1<=y<=100, 1<=s1<=100, 10<=p1<=100, s1 s2<=100, p1p2<=100). The input ends with n = m = 0.

Output
For each test case, print the maximal number of people you can serve.

Sample Input

2 100
10 8 10 10 13 11
12 20 6 10 17 24
3 65
10 5 7 10 13 14
10 5 8 11 14 15
10 5 9 12 15 16
0 0

Sample Output

5
2

Source
2009 “NIT Cup” National Invitational Contest
二分+完全背包
由于不好计算具体的人的数量,可以提前估计好人的数量,采用二分的方式进行寻找答案

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <queue>
#include <map>
#include <algorithm>
#define INF 0x3f3f3f3f
using namespace std;

typedef long long LL;

const int MAX = 1e5+10;

int n,m;

int L,R;

int Dp[800000];

struct node
{
    int x;
    int y;
    int s1;
    int p1;
    int s2;
    int p2;
}Th[110];

int w[3],v[3];

int  Judge()//估计人的数量范围
{
    int tmp=INF;
    for(int i=1;i<=n;i++)
    {
        if(m*1.0/Th[i].p1*Th[i].s1>m*1.0/Th[i].p2*Th[i].s2)
        {
            tmp=min(tmp,(m/Th[i].p1*Th[i].s1+Th[i].y)/Th[i].x);
        }
        else
        {
            tmp=min(tmp,(m/Th[i].p2*Th[i].s2+Th[i].y)/Th[i].x);
        }
    }
    return tmp+10;
}

int Backpack(int s,int need)//完全背包
{
    for(int i=1;i<=need+Th[s].s2;i++)
    {
        Dp[i]=INF;
    }
    Dp[0]=0;
    int tmp=need+Th[s].s2;
    w[0]=Th[s].p1;
    w[1]=Th[s].p2;
    v[0]=Th[s].s1;
    v[1]=Th[s].s2;
    for(int i=0;i<2;i++)
    {
        for(int j=v[i];j<=tmp;j++)
        {
            Dp[j]=min(Dp[j-v[i]]+w[i],Dp[j]);
        }
    }
    int Max=INF;
    for(int i=need;i<=tmp;i++)
    {
        Max=min(Max,Dp[i]);
    }
    return Max;
}

bool BB(int num)
{
    int sum=0;
    for(int i=1;i<=n;i++)
    {
        int tmp=num*Th[i].x-Th[i].y;
        if(tmp<=0)
        {
            continue;
        }
        sum+=Backpack(i,tmp);
        if(sum>m)
        {
            return false;
        }
    }
    return true;
}
int main()
{
    while(scanf("%d %d",&n,&m)&&(n||m))
    {
        for(int i=1;i<=n;i++)
        {
            scanf("%d %d %d %d %d %d",&Th[i].x,&Th[i].y,&Th[i].s1,&Th[i].p1,&Th[i].s2,&Th[i].p2);
        }
        L=1;
        R=Judge();
        int ans=0;
        while(L<=R)
        {
            int mid=(L+R)>>1;
            if(BB(mid))
            {
                ans=max(ans,mid);
                L=mid+1;
            }
            else
            {
                R=mid-1;
            }
        }
        printf("%d\n",ans);

    }
    return 0;
}

转载于:https://www.cnblogs.com/juechen/p/5255965.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值