【贪心算法】POJ-1862 简单哈夫曼

一、题目

Description

Our chemical biologists have invented a new very useful form of life called stripies (in fact, they were first called in Russian - polosatiki, but the scientists had to invent an English name to apply for an international patent). The stripies are transparent amorphous amebiform creatures that live in flat colonies in a jelly-like nutrient medium. Most of the time the stripies are moving. When two of them collide a new stripie appears instead of them. Long observations made by our scientists enabled them to establish that the weight of the new stripie isn't equal to the sum of weights of two disappeared stripies that collided; nevertheless, they soon learned that when two stripies of weights m1 and m2 collide the weight of resulting stripie equals to 2sqrt(m1m2). Our chemical biologists are very anxious to know to what limits can decrease the total weight of a given colony of stripies.
You are to write a program that will help them to answer this question. You may assume that 3 or more stipies never collide together.

Input

The first line of the input contains one integer N (1 <= N <= 100) - the number of stripies in a colony. Each of next N lines contains one integer ranging from 1 to 10000 - the weight of the corresponding stripie.

Output

The output must contain one line with the minimal possible total weight of colony with the accuracy of three decimal digits after the point.

Sample Input

3
72
30
50

Sample Output

120.000

二、思路&心得

  • 很水的一道题。。。类似哈夫曼树的构造过程,可以用排序做,也可以用优先队列做。

三、代码

1.排序

#include<cstdio>
#include<cmath>
#include<algorithm>
using namespace std;
const int MAX_N = 105;

int N;

float num[MAX_N], s;

void solve() {
    for (int i = 0; i < N; i ++) {
        scanf("%f", &num[i]);
    } 
    sort(num, num + N);
    s = num[N - 1];
    for (int i = N - 2; i >= 0; i --) {
        s = 2 * sqrt(s * num[i]);
    }
    printf("%.3f\n", s);
} 

int main() {
    while (~scanf("%d", &N)) {
        solve();
    }
    return 0;
}

2.优先队列

#include<cstdio>
#include<cmath>
#include<queue>
using namespace std;

int N;

float num, t1, t2;

priority_queue<float> que;

void solve() {
    while (N --) {
        scanf("%f", &num);
        que.push(num);      
    }
    while (que.size() > 1) {
        t1 = que.top(); que.pop();
        t2 = que.top(); que.pop();
        num = 2 * sqrt(t1 * t2);
        que.push(num);
    }
    num = que.top(); que.pop();
    printf("%.3f\n", num);
} 

int main() {
    while (~scanf("%d", &N)) {
        solve();
    }
    return 0;
}

转载于:https://www.cnblogs.com/CSLaker/p/7329323.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值