九度OJ 1042:Coincidence(公共子序列) (DP)

时间限制:1 秒

内存限制:32 兆

特殊判题:否

提交:2303

解决:1241

题目描述:

Find a longest common subsequence of two strings.

输入:

First and second line of each input case contain two strings of lowercase character a…z. There are no spaces before, inside or after the strings. Lengths of strings do not exceed 100.

输出:

For each case, output k – the length of a longest common subsequence in one line.

样例输入:
abcd
cxbydz
样例输出:
2
来源:
2008年上海交通大学计算机研究生机试真题

思路:

动态规划,分别设置两个指针,分别从头到尾搜索两个数组,最后得到的就是最大值。

动态规划的关键方程是:

if (a[i] == b[j])
     res[i+1][j+1] = res[i][j]+1;
else
     res[i+1][j+1] = max(res[i+1][j], res[i][j+1]);

代码:

#include <stdio.h>
#include <string.h>
 
#define N 100
#define max(a, b) (((a)>(b)) ? (a) : (b))
 
int main(void)
{
    int na, nb, i, j;
    char a[N+1], b[N+1];
    int res[N+1][N+1];
 
    while (scanf("%s%s", a, b) != EOF)
    {
        na = strlen(a);
        nb = strlen(b);
        memset(res, 0, sizeof(res));
        for (i=0; i<na; i++)
        {
            for (j=0; j<nb; j++)
            {
                if (a[i] == b[j])
                    res[i+1][j+1] = res[i][j]+1;
                else
                    res[i+1][j+1] = max(res[i+1][j], res[i][j+1]);
            }
        }
        /*
        for (i=1; i<=na; i++)
        {
            for (j=1; j<=nb; j++)
            {
                printf("%d ", res[i][j]);
            }
            printf("\n");
        }
        */
        printf("%d\n", res[na][nb]);
    }
 
    return 0;
}
/**************************************************************
    Problem: 1042
    User: liangrx06
    Language: C
    Result: Accepted
    Time:0 ms
    Memory:912 kb
****************************************************************/


转载于:https://www.cnblogs.com/liangrx06/p/5083989.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值