hdu 5826 physics 物理题

physics

题目连接:

http://acm.hdu.edu.cn/showproblem.php?pid=5826

Description

There are n balls on a smooth horizontal straight track. The track can be considered to be a number line. The balls can be considered to be particles with the same mass.

At the beginning, ball i is at position Xi. It has an initial velocity of Vi and is moving in direction Di.(Di∈−1,1)
Given a constant C. At any moment, ball its acceleration Ai and velocity Vi have the same direction, and magically satisfy the equation that Ai * Vi = C.
As there are multiple balls, they may collide with each other during the moving. We suppose all collisions are perfectly elastic collisions.

There are multiple queries. Each query consists of two integers t and k. our task is to find out the k-small velocity of all the balls t seconds after the beginning.

  • Perfectly elastic collision : A perfectly elastic collision is defined as one in which there is no loss of kinetic energy in the collision.
  • Input

    The first line contains an integer T, denoting the number of testcases.

For each testcase, the first line contains two integers n <= 10^5 and C <= 10^9.
n lines follow. The i-th of them contains three integers Vi, Xi, Di. Vi denotes the initial velocity of ball i. Xi denotes the initial position of ball i. Di denotes the direction ball i moves in.

The next line contains an integer q <= 10^5, denoting the number of queries.
q lines follow. Each line contains two integers t <= 10^9 and 1<=k<=n.
1<=Vi<=10^5,1<=Xi<=10^9

Output

For each query, print a single line containing the answer with accuracy of 3 decimal digits.

Sample Input

1
3 7
3 3 1
3 10 -1
2 7 1
3
2 3
1 2
3 3

Sample Output

6.083
4.796
7.141

Hint

题意

给你n个球,以及球的位置,球初始方向,球保证都在x轴上。

而且V[i]*A[i] = C

现在有Q次询问,问你在第t秒,第k大的速度是多少。

题解:

弹性碰撞,那么其实就是交换速度,那么就和位置无关了。

第k大,其实就是开始速度第k大的球。

速度怎么求呢? V[i]*A[i] = C ,那么 Cdt = V[i]dV,然后积分 2k+2Ct = V[i]^2,把初速度带进去,把k解出来就好了。

(其实功率是守恒的,用这个做也很简单

代码

#include <bits/stdc++.h>

using namespace std;

int V[100010];
int n,c,t,k,q,T;

double solve(int v,int t)
{
    return (sqrt(1.0*v*v+2.0*t*c));
}

int main()
{
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d%d",&n,&c);
        for(int i=1;i<=n;i++)
        {
            int v,x,d;
            scanf("%d%d%d",&v,&x,&d);
            V[i]=v;
        }
        sort(V+1,V+1+n);
        scanf("%d",&q);
        while(q--)
        {
            scanf("%d%d",&t,&k);
            printf("%.3f\n",solve(V[k],t));
        }
    }
    return 0;
}

转载于:https://www.cnblogs.com/qscqesze/p/5763104.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值