HDU1250 Hat's Fibonacci (大数相加)(Java题解)

Hat's Fibonacci

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 14587    Accepted Submission(s): 4853

Problem Description

A Fibonacci sequence is calculated by adding the previous two members the sequence, with the first two members being both 1.
F(1) = 1, F(2) = 1, F(3) = 1,F(4) = 1, F(n>4) = F(n - 1) + F(n-2) + F(n-3) + F(n-4)
Your task is to take a number as input, and print that Fibonacci number.

Input

Each line will contain an integers. Process to end of file.

Output

For each case, output the result in a line.

Sample Input

 
 

100

Sample Output

 
 

4203968145672990846840663646 Note: No generated Fibonacci number in excess of 2005 digits will be in the test data, ie. F(20) = 66526 has 5 digits.

 

代码如下:

import java.math.BigInteger;
import java.util.Scanner;
public class Main{
 static BigInteger f[]=new BigInteger[7045];
 public static void main(String[] args){
 dabiao();
 Scanner sc=new Scanner(System.in);
 while(sc.hasNext()){
 int n=sc.nextInt();
 System.out.println(f[n]);
   }
 }
 private static void dabiao(){
 f[1]=new BigInteger("1");
 f[2]=new BigInteger("1");
 f[3]=new BigInteger("1");
 f[4]=new BigInteger("1");
 for(int i=5;i<f.length;i++){
 f[i]=f[i-1].add(f[i-2]).add(f[i-3]).add(f[i-4]);
   }
 }
}

转载于:https://www.cnblogs.com/jianqiao123/p/11202656.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值