POJ - 3233 Matrix Power Series (矩阵快速幂)

Given a n × n matrix A and a positive integer k, find the sum S = A + A2 + A3 + … + Ak.

Input

The input contains exactly one test case. The first line of input contains three positive integers n (n ≤ 30), k (k ≤ 109) and m (m < 104). Then follow n lines each containing n nonnegative integers below 32,768, giving A’s elements in row-major order.

Output

Output the elements of S modulo m in the same way as A is given.

Sample Input

2 2 4
0 1
1 1

Sample Output

1 2
2 3

思路,把矩阵看成一个数字。

#include<iostream>
#include<algorithm>
#include<vector>
#include<stack>
#include<queue>
#include<map>
#include<set>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<ctime>
#define fuck(x) cout<<#x<<" = "<<x<<endl;
#define debug(a,i) cout<<#a<<"["<<i<<"] = "<<a[i]<<endl;
#define ls (t<<1)
#define rs ((t<<1)+1)
using namespace std;
typedef long long ll;
typedef unsigned long long ull;
const int maxn = 100086;
const int maxm = 100086;
const int inf = 2.1e9;
const ll Inf = 999999999999999999;
//const int mod = 1000000007;
const double eps = 1e-6;
const double pi = acos(-1);

int n,k,mod;

struct Matrix{
    int mp[70][70];
};
Matrix a;


Matrix mul(Matrix a,Matrix b,int n){
    Matrix ans;
    for(int i=1;i<=n;i++){
        for(int j=1;j<=n;j++){
            ans.mp[i][j]=0;
            for(int k=1;k<=n;k++){
                ans.mp[i][j]+=a.mp[i][k]*b.mp[k][j];
            }
            ans.mp[i][j]%=mod;
        }
    }
    return ans;
}

Matrix q_pow(Matrix a,int b,int n){
    Matrix ans;
    memset(ans.mp,0,sizeof(ans.mp));
    for(int i=1;i<=n;i++){
        ans.mp[i][i]=1;
    }
    while (b){
        if(b&1){
            ans=mul(ans,a,n);
        }
        b>>=1;
        a=mul(a,a,n);
    }
    return ans;
}

Matrix mul1(Matrix a,Matrix b,int n){
    Matrix ans;
    for(int i=1;i<=n;i++){
        for(int j=1;j<=n;j++){
            ans.mp[i][j]=0;
            for(int k=1;k<=n;k++){
                ans.mp[i][j]+=a.mp[i][k+n]*b.mp[k][j];
            }
            ans.mp[i][j]%=mod;
        }
    }
    return ans;
}

int main()
{
    scanf("%d%d%d",&n,&k,&mod);
    for(int i=1;i<=n;i++){
        for(int j=1;j<=n;j++){
            scanf("%d",&a.mp[i][j]);
            a.mp[i][j]%=mod;
        }
    }
    for(int i=1;i<=n;i++){
        a.mp[i][i+n]=1;
        a.mp[i+n][i+n]=1;
    }
    Matrix tmp=q_pow(a,k-1,n*2);
    Matrix b=tmp;
    tmp = mul(tmp,a,n);
    a=mul1(b,a,n);
    for(int i=1;i<=n;i++){
        for(int j=1;j<n;j++){
            printf("%d ",(tmp.mp[i][j]+a.mp[i][j])%mod);
        }
        printf("%d\n",(tmp.mp[i][n]+a.mp[i][n])%mod);
    }
    return 0;
}
View Code

转载于:https://www.cnblogs.com/ZGQblogs/p/10878004.html

以下是Java解决POJ3233—矩阵幂序列问题的代码和解释: ```java import java.util.Scanner; public class Main { static int n, k, m; static int[][] A, E; public static void main(String[] args) { Scanner sc = new Scanner(System.in); n = sc.nextInt(); k = sc.nextInt(); m = sc.nextInt(); A = new int[n][n]; E = new int[n][n]; for (int i = 0; i < n; i++) { for (int j = 0; j < n; j++) { A[i][j] = sc.nextInt() % m; E[i][j] = (i == j) ? 1 : 0; } } int[][] res = matrixPow(A, k); int[][] ans = matrixAdd(res, E); printMatrix(ans); } // 矩阵乘法 public static int[][] matrixMul(int[][] a, int[][] b) { int[][] c = new int[n][n]; for (int i = 0; i < n; i++) { for (int j = 0; j < n; j++) { for (int k = 0; k < n; k++) { c[i][j] = (c[i][j] + a[i][k] * b[k][j]) % m; } } } return c; } // 矩阵快速幂 public static int[][] matrixPow(int[][] a, int b) { int[][] res = E; while (b > 0) { if ((b & 1) == 1) { res = matrixMul(res, a); } a = matrixMul(a, a); b >>= 1; } return res; } // 矩阵加法 public static int[][] matrixAdd(int[][] a, int[][] b) { int[][] c = new int[n][n]; for (int i = 0; i < n; i++) { for (int j = 0; j < n; j++) { c[i][j] = (a[i][j] + b[i][j]) % m; } } return c; } // 输出矩阵 public static void printMatrix(int[][] a) { for (int i = 0; i < n; i++) { for (int j = 0; j < n; j++) { System.out.print(a[i][j] + " "); } System.out.println(); } } } ``` 解释: 1. 首先读入输入的n、k、m和矩阵A,同时初始化单位矩阵E。 2. 然后调用matrixPow函数求出A的k次幂矩阵res。 3. 最后将res和E相加得到结果ans,并输出。 4. matrixMul函数实现矩阵乘法,matrixPow函数实现矩阵快速幂matrixAdd函数实现矩阵加法,printMatrix函数实现输出矩阵。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值