二分图最少点覆盖

http://poj.org/problem?id=3041

Asteroids
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 14218 Accepted: 7736

Description

Bessie wants to navigate her spaceship through a dangerous asteroid field in the shape of an N x N grid (1 <= N <= 500). The grid contains K asteroids (1 <= K <= 10,000), which are conveniently located at the lattice points of the grid. 

Fortunately, Bessie has a powerful weapon that can vaporize all the asteroids in any given row or column of the grid with a single shot.This weapon is quite expensive, so she wishes to use it sparingly.Given the location of all the asteroids in the field, find the minimum number of shots Bessie needs to fire to eliminate all of the asteroids.

Input

* Line 1: Two integers N and K, separated by a single space. 
* Lines 2..K+1: Each line contains two space-separated integers R and C (1 <= R, C <= N) denoting the row and column coordinates of an asteroid, respectively.

Output

* Line 1: The integer representing the minimum number of times Bessie must shoot.

Sample Input

3 4
1 1
1 3
2 2
3 2

Sample Output

2

Hint

INPUT DETAILS: 
The following diagram represents the data, where "X" is an asteroid and "." is empty space: 
X.X 
.X. 
.X.
 

OUTPUT DETAILS: 
Bessie may fire across row 1 to destroy the asteroids at (1,1) and (1,3), and then she may fire down column 2 to destroy the asteroids at (2,2) and (3,2).
题意:

在一块N*N的田野中,有伞兵降落,用坐标表示,问每行和每列都有机枪,可以消灭一行和一列的敌人,问最少用多少个机枪能消灭完所有的敌人;

分析;

二分图最少点覆盖:

最小覆盖: 最小覆盖要求用最少的点(X集合或Y集合的都行)让每条边都至少和其中一个点关联。可以证明:最少的点(即覆盖数)=最大匹配数

把行数构成x集合,列数构成y集合,按照坐标连线;

程序;

#include"string.h"
#include"stdio.h"
#include"iostream"
#include"queue"
#define M 10009
#define inf 999999999
using namespace std;
struct st
{
    int u,v,next;
}edge[M];
int head[M],use[M],t,x[M],y[M];
void init()
{
    t=0;
    memset(head,-1,sizeof(head));
}
void add(int u,int v)
{
    edge[t].u=u;
    edge[t].v=v;
    edge[t].next=head[u];
    head[u]=t++;
}
int finde(int u)
{
    for(int i=head[u];i!=-1;i=edge[i].next)
    {
        int v=edge[i].v;
        if(!use[v])
        {
            use[v]=1;
            if(!y[v]||finde(y[v]))
            {
                use[v]=1;
                y[v]=u;
                x[u]=v;
                return 1;
            }
        }
    }
    return 0;
}
int max_match(int n)
{
    int ans=0;
    memset(x,0,sizeof(x));
    memset(y,0,sizeof(y));
    for(int i=1;i<=n;i++)
    {
        if(!x[i])
        {
            memset(use,0,sizeof(use));
            ans+=finde(i);
        }
    }
    return ans;
}
int main()
{
    int n,m,a,b;
    while(scanf("%d%d",&n,&m)!=-1)
    {
        init();
        while(m--)
        {
            scanf("%d%d",&a,&b);
            add(a,n+b);
        }
        int ans=max_match(n);
        printf("%d\n",ans);
    }
    return 0;
}


转载于:https://www.cnblogs.com/mypsq/p/4348222.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值