TJUoj水题 数羊

***After a long night of coding, Charles Pearson Peterson is having trouble sleeping. This is not only because he is still thinking about the problem he is working on but also due to drinking too much java during the wee hours. This happens frequently, so Charles has developed a routine to count sheep. Not the animal, but the word. Specifically, he thinks of a list of words, many of which are close in spelling to “sheep”, and then counts how many actually are the word “sheep”. Charles is always careful to be case-sensitive in his matching, so “Sheep” is not a match. You are to write a program that helps Charles count “sheep”.
Input

Input will consist of multiple problem instances. The first line will consist of a single positive integer n ≤ 20, which is the number of problem instances. The input for each problem instance will be on two lines. The first line will consist of a positive integer m ≤ 10 and the second line will consist of m words, separated by a single space and each containing no more than 10 characters.

Output

For each problem instance, you are to produce one line of output in the format:

Case i: This list contains n sheep.
The value of i is the number of the problem instance (we assume we start numbering at 1) and n is the number of times the word “sheep” appears in the list of words for that problem instance. Two successive lines should be separated by a single blank line, but do not output any trailing blank line.

Sample Input

4
5
shep sheeps sheep ship Sheep
7
sheep sheep SHEEP sheep shepe shemp seep
10
sheep sheep sheep sheep sheep sheep sheep sheep sheep sheep
4
shape buffalo ram goat
Sample Output

Case 1: This list contains 1 sheep.

Case 2: This list contains 3 sheep.

Case 3: This list contains 10 sheep.

Case 4: This list contains 0 sheep.


题意:计算与sheep相同的单词个数。
注意:每个样例之间输出一个空行

#include<stdio.h>
#include<string.h>
#define N 100
char str[N];

int main()
{
    int t;
    int i,count,n,k;
    scanf("%d",&t);
    k = t;
    while( t --)
    {
        scanf("%d",&n);
        count = 0;
        memset(str,0,sizeof(str));
        for( i =1; i <= n; i ++)
        {
            scanf("%s",str);
            if(!strcmp(str,"sheep"))
                count ++;
        }
        if(t!=0)
            printf("Case %d: This list contains %d sheep.\n\n",k-t,count);
        else
            printf("Case %d: This list contains %d sheep.\n",k-t,count);
    }
    return 0;
}

后记:纪念性的水题,省赛完后第一道刷的题,也是第一次在tjuoj上刷的题。以后好好刷题吧,争取今后超过隔壁大佬

转载于:https://www.cnblogs.com/hellocheng/p/7350162.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值