2017 Multi-University Training Contest - Team 5 1006 Rikka with Graph

 题目链接http://acm.hdu.edu.cn/showproblem.php?pid=6090

Problem Description
As we know, Rikka is poor at math. Yuta is worrying about this situation, so he gives Rikka some math tasks to practice. There is one of them:

For an undirected graph G with n nodes and m edges, we can define the distance between (i,j) (dist(i,j)) as the length of the shortest path between i and j. The length of a path is equal to the number of the edges on it. Specially, if there are no path between i and j, we make dist(i,j) equal to n.

Then, we can define the weight of the graph G (wG) as ni=1nj=1dist(i,j).

Now, Yuta has n nodes, and he wants to choose no more than m pairs of nodes (i,j)(ij) and then link edges between each pair. In this way, he can get an undirected graph G with n nodes and no more than m edges.

Yuta wants to know the minimal value of wG.

It is too difficult for Rikka. Can you help her?  

In the sample, Yuta can choose (1,2),(1,4),(2,4),(2,3),(3,4).
 

 

Input
The first line contains a number t(1t10), the number of the testcases.

For each testcase, the first line contains two numbers n,m(1n106,1m1012).
 

 

Output
For each testcase, print a single line with a single number -- the answer.
 

 

Sample Input
1 4 5
 

 

Sample Output
14
 
 
找规律。其实可以让1连接其他所有的点,当m = n -1时,比如n = 6, m = 5。可以这样连,1到所以的点都是1,其他的点除了到1的距离是1的话都是2。
1、m  <= n-1时,假设有x个点没有连接任何点,1连接的是 m + x*n ,其他m个连接1的点都是1+2*(m-1)+x*n ,x个没有连接的点都是 n*(n-1)。所以答案是m+x*n+m*(1+2*(m-1)+x*n)+x*n*(n-1),化简就是2*m*m+x*n*m+x*n*n。
2、n - 1 < m < n*(n-1)/2是就好办了,就是2*(n-1)*(n-1) - 2 * x

3、m >= n*(n-1)/2 就是n*(n-1)。

 

#include <iostream>
#include <stdio.h>
#include <string.h>
#define ll long long
using namespace std;

int main() {
    int t;
    scanf("%d", &t);
    while(t--) {
        ll n, m;
        scanf("%lld %lld", &n, &m);
        if(m <= n-1) {
            ll x = n-1-m;
            printf("%lld\n",2*m*m+x*n*m+x*n*n);
        } else if(m >= n*(n-1)/2) {
            printf("%lld\n",n*(n-1));
        } else {
            ll x = m - n + 1;
            printf("%lld\n",2*(n-1)*(n-1) - 2 * x);
        }
    }
    return 0;
}

 

转载于:https://www.cnblogs.com/xingkongyihao/p/7308188.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值