POJ 2524 Ubiquitous Religions 简单并查集

本文介绍了一个名为UbiquitousReligions的问题,该问题是通过询问学生之间的宗教信仰相似性来估算大学校园内不同宗教信仰的最大数量。提供了一种使用并查集的数据结构解决方案,并附带了实现代码。
摘要由CSDN通过智能技术生成
原题:
 
------------------------------------------------------------------------
 
Ubiquitous Religions
Time Limit: 5000MS Memory Limit: 65536K
Total Submissions: 30707 Accepted: 14882

Description

There are so many different religions in the world today that it is difficult to keep track of them all. You are interested in finding out how many different religions students in your university believe in.

You know that there are n students in your university (0 < n <= 50000). It is infeasible for you to ask every student their religious beliefs. Furthermore, many students are not comfortable expressing their beliefs. One way to avoid these problems is to ask m (0 <= m <= n(n-1)/2) pairs of students and ask them whether they believe in the same religion (e.g. they may know if they both attend the same church). From this data, you may not know what each person believes in, but you can get an idea of the upper bound of how many different religions can be possibly represented on campus. You may assume that each student subscribes to at most one religion.

Input

The input consists of a number of cases. Each case starts with a line specifying the integers n and m. The next m lines each consists of two integers i and j, specifying that students i and j believe in the same religion. The students are numbered 1 to n. The end of input is specified by a line in which n = m = 0.

Output

For each test case, print on a single line the case number (starting with 1) followed by the maximum number of different religions that the students in the university believe in.

Sample Input

10 9
1 2
1 3
1 4
1 5
1 6
1 7
1 8
1 9
1 10
10 4
2 3
4 5
4 8
5 8
0 0

Sample Output

Case 1: 1
Case 2: 7


用father数组的记录root;
再遍历father数组if(x.father==x) 记录一个
然后输出记录值;


代码如下:
#include<stdio.h>
int fa[50010];
void makeset(int n){
	for(int i=1;i<=n;i++){
		fa[i]=i;
	}
}
int find(int x){
	return x==fa[x]?fa[x]:fa[x]=find(fa[x]);
}
void fu(int x,int y){//把y并入x中 
	x=find(x);y=find(y);
	if(x==y) return;
	fa[y]=x;
}
int main(){
	int n,m,ii=1;
	while(scanf("%d%d",&n,&m)&&n||m){
		makeset(n);
		while(m--){
			int x,y;
			scanf("%d%d",&x,&y);
			fu(x,y);
		}
		int z=0;
		for(int i=1;i<=n;i++){
			if(fa[i]==i) z++;
 		}
 		printf("Case %d: %d\n",ii,z);
		ii++;
	}
	return 0;
}

  

转载于:https://www.cnblogs.com/liujiaqi-Boke/p/5512395.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值