Sticks(Central Europe 1995) (DFS)

Sticks(Central Europe 1995)

Time Limit:1000MS     Memory Limit:10000KB     64bit IO Format:%I64d & %I64u

Description

George took sticks of the same length and cut them randomly until all parts became at most 50 units long. Now he wants to return sticks to the original state, but he forgot how many sticks he had originally and how long they were originally. Please help him and design a program which computes the smallest possible original length of those sticks. All lengths expressed in units are integers greater than zero.

Input

The input contains blocks of 2 lines. The first line contains the number of sticks parts after cutting, there are at most 64 sticks. The second line contains the lengths of those parts separated by the space. The last line of the file contains zero.

Output

The output should contains the smallest possible length of original sticks, one per line.

Sample Input

9
5 2 1 5 2 1 5 2 1
4
1 2 3 4
0

Sample Output

6
5
题目简单翻译:
给你一个数n:
然后给你n个小木棍,把他们分成若干组,每组的总长度相等,求最短的总长度,使每组的总长度相等。
 
思路:
dfs,剪枝
把它分成若干组,从大到小搜索,使它们成为一组,直到搜到结果。
 
代码:
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;

int n,t[100],vis[100];
bool Get_Ans;
int Sum;
void dfs(int Length,int Now_Sum,int Now_Groups,int Aim_Groups,int Now_Position)
{
    if(Now_Groups==Aim_Groups)//所有的组都收集齐了
    {
        Get_Ans=true;
        return;
    }
    if(Now_Sum==Length) //收集齐了一组
    {
        dfs(Length,0,Now_Groups+1,Aim_Groups,0);
    }
    for(int i=Now_Position;i<n&&!Get_Ans;i++)
    {
        if(!vis[i]&&t[i]+Now_Sum<=Length)
        {
            vis[i]=1;
            dfs(Length,Now_Sum+t[i],Now_Groups,Aim_Groups,i);
            if(Get_Ans) return;
            vis[i]=0;
            if(Now_Sum==0||Now_Sum+t[i]==Length) return ;//剪枝
        }
    }
}
bool judge(int Length,int Groups)
{
    memset(vis,0,sizeof vis);
    Get_Ans=false;
    dfs(Length,0,0,Groups,0);
    return Get_Ans;
}
bool cmp(int a,int b)
{
    return a>b;
}
int main()
{
    while(scanf("%d",&n)!=EOF&&n)
    {
        Sum=0;
        for(int i=0;i<n;i++) scanf("%d",&t[i]),Sum+=t[i];
        sort(t,t+n,cmp);
        int Ans=Sum;
        for(int i=n;i>1;i--)
            if(Sum%i==0&&t[n-1]<=Sum/i&&judge(Sum/i,i))
            {
                Ans=Sum/i;
                break;
            }
        printf("%d\n",Ans);
    }
    return 0;
}

转载于:https://www.cnblogs.com/I-love-HLD/p/4625255.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值