Steps POJ - 2590

Steps
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 8219 Accepted: 3747
Description


One steps through integer points of the straight line. The length of a step must be nonnegative and can be by one bigger than, equal to, or by one smaller than the length of the previous step. 
What is the minimum number of steps in order to get from x to y? The length of the first and the last step must be 1.
Input


Input consists of a line containing n, the number of test cases.
Output


For each test case, a line follows with two integers: 0 <= x <= y < 2^31. For each test case, print a line giving the minimum number of steps to get from x to y.
Sample Input


3
45 48
45 49
45 50
Sample Output


3
3

4

贪心做法,先把 x写成1+2+3+.....+n+n-1+n-2+n-3+....+2+1的形式,再把剩下的放进去。

上面的式子等于 n^2,所以先判断x是否为平方数,如果是的话直接输出 2*k-1,如果不是在加上剩下。

#include<map>
#include<stack>
#include<queue>
#include<math.h>
#include<vector>
#include<string>
#include<stdio.h>
#include<iostream>
#include<string.h>
#include<algorithm>
#define mem(a,b) memset(a,b,sizeof(a))
#define maxn 1100000
#define maxm 1000000000005
#define mod 1000000007
#define ll long long
#define inf 0x3f3f3f3f
using namespace std;
int main(){
    int t;
    scanf("%d",&t);
    while(t--){
     ll x,y;scanf("%lld%lld",&x,&y);
     if(x==y){
        printf("0\n");continue;
     }
     ll k=sqrt((y-x)*1.0);
     if(k*k==y-x)printf("%lld\n",2*k-1);
     else {
        ll ans=(y-x)-k*k;
        ll ans1=2*k-1;
        while(ans!=0){
           ans1+=(ans/k);
           ans%=k;
           k--;
        }
        printf("%lld\n",ans1);
     }
    }
}


转载于:https://www.cnblogs.com/da-mei/p/9053229.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值